Battery issue

Abhishek CrmAbhishek Crm Level 1
edited August 14 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name:ROG Phone 5
  2. Firmware Version:
  3. Rooted or not:Not rooted
  4. Frequency of Occurrence:Most off the time
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

My phone shuts down when ever the battery reaches 20% and when I fully charge it it only shows 99% even if I charge it an hour extra and I have already used the phone now for about an hour and it is still showing 99% pls fix this issue

Comments

  • Have your phone upgraded to the latest version. Format the phone and check if everything is fine. If not recert back

  • Hi Abhishek Crm,

    Make sure you are on the latest software version which is .49 if not, you can check by

    Go to setting => System => About => Software information.

    1. Charge the battery to 100% & use as per your normal usage pattern

    2. When the battery strength reaches 10%, go to settings = Battery => Tap on the battery icon & share the graph

    3. settings => Battery => Check the screen & share the same

    Factory reset once

  • Neel007Neel007 Level 2

    My device is also stuck in 99% after 30 min charge 99% is showing when u disconnect the charger then 100% battery is showing same issue is occured every time . After format this issue is not solve.

  • SwaggiePSwaggieP Level 1

    Hi all,

    My Rog Phone 5 is with the latest software update.

    It shut down automatically at around 17%. This happened twice already. I try to charge my phone to 100% but after this happen, it is stuck in 99% after 1hr of charging.


    Now I use yhe phone(playing games) for around 30 mins and it is still showing 99% and not going down.


    Any idea for all these problems? Any solution? Or need to wait a new update?

  • VassVass Level 1

    I have the same issue mine gets shut down at 25% i have also tried factory reset nothing worked it doesn't even charge to 100 always stuck at 99

    i cant find any solution.

This discussion has been closed.