Issue with Multi-touch and blurry selfie camera

Hindra`Hindra` Level 1
edited July 28 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG 5 ASUS_1005DA ZS683KS
  2. Firmware Version: WW_18.0840.2104.49
  3. Rooted or not: NOT
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): All apps and OS

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

As I notice when playing CODM this morning when I tried to use 4-fingers at once only 3 or 2 fingers are being registered to the phone and I've seen such scenario on ROG 3 and disabled the screenshot gesture on settings but still having the same issue.

ROG 3 and 5 are both different phone so I guess that is irrelevant to start with. I just recently bought this phone 1 day ago. I even sent a support ticket on the seller but even them are so slow. Refund is a slow process as well and they will ask confirmation on ASUS for sure. I am still covered by 7-days warranty of seller and should give me a brandnew phone or refund since I bought this on official ROG Shopee account

Another issue is the front camera being blurred and I can even compare this to a 10-year old phone with the quality it produce. For your reference I can PM the photos for your reference but I will include the video I recorded about the issue on Multi-Touch.

PS: I'm not using any screen protector.

Comments

  • Hindra`Hindra` Level 1

    The annoying part is that they instruct me to wait for another 2 days cause its weekend how is that even tolerable I'm still covered by my 7days warranty and they should accommodate my request since it still counts to my warranty. It will be more headache if this continue to RMA right?

  • Hindra`Hindra` Level 1

    Is there anyone that can prove that this happen to their phone as well? Would be great if they can do the same setup using 2 finger gloves only.

  • I'm facing same issue as well... bought this product 2 days back..I tried playing pubg and all of a sudden it's not firing.. movement stops...scope doesn't open when I press..I checked murli touch test using an app..it doesn't register all my finger at once sometimes...instead of making all this crazy graphic and high end gaming blah blah blah., They should work on their display..my one plus 5 t gives me exact touch response ..it's just too old for pubg thatz it..hope asus got some technicians out there

  • And the funny part ..it doesn't respond well to my finger sleeves...what nonsense.. again my years old phone gives me better experience with their touch...what's the point of having all the specifications for gaming..and people call it a gaming beast and the touch doesn't respond...oh lord

  • Hindra`Hindra` Level 1

    I was talking to the seller and asking for the same test on a new phone that means we can isolate the whole issue and I can know if I'm not the only one having the same issue so for sure this is a build flaw all my phones and iPad works well with sleeves.

    Let me know if you are using 2 sleeves only but using 4 fingers to play? For what I notice as I test it we should use sleeves on all fingers that we will use on the device. But I'm not sure yet I will need to get a new pair of sleeves to try but even so that is annoying gaming line but yet they can't even work well with sleeves? LOL!

  • Hindra`Hindra` Level 1

    Can you test it as well to use 4 fingers or more as long you use sleeves on each fingers as well?

  • I've done my best to replicate this behavior but my ROG 5 display doesn't fail even once so my guess is that your display must be defective. Visit a service center

This discussion has been closed.