[Bug Report] Swipe-up Gesture Navigation breaks Accessibility-based Navigation Apps

LambasteLambaste Level 1
edited February 19 in ZenFone 6

Please tell us some basic information before asking for help:

  1. Model Name: ZS630KL
  2. Firmware Version: WW_18.0610.2011.107
  3. Rooted or not: No
  4. Frequency of Occurrence: Constant
  5. APP Name & APP Version (If your issue relates to the app): Edge Gestures 1.9.4, Fluid Navigation Gestures 2.0-beta11

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

In the current stable Android 11 update, enabling Asus' custom implementation of swipe-up gesture navigation breaks 3rd party gesture navigation apps that implement edge swiping. When the built-in swipe-up navigation is turned on, swipes made to the left and right screen edges fail to consistently trigger/fire the 3rd party app.

This can be reproduced by very quickly and consecutively swiping either screen edge after setting up an action. The first few swipes will be correctly recognized by the app, but later ones will not. Slow and deliberate swipes seem to have a better chance, but neither fires consistently.

The touch event by itself is recognized by the OS - Enabling pointer location/taps in Developer options confirm this. It just seems like the event is simply not propagating to the app from surfaceflinger. If I were to guess, it seems to indicate that some setting that was intended for the bottom edge (swipe sensitivity, threshold, etc) gets applied to all four screen edges. Another potential reason could be some kind of rate-limiting applied to the number of touch/swipe events.

Regardless of the reason, it's a clear regression as this issue was present in neither Android 9 nor 10. And as mentioned earlier, it is specific to Asus' swipe-up gesture implementation - None of the other system navigation modes have this issue.

I'd greatly appreciate it this could be fixed in the next update. @Anders_ASUS

Comments

This discussion has been closed.