Phone hangs after connecting to TwinDock II, and unable to switch on

EasothEasoth Level 1
edited September 2020 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: ROG 2
  2. Firmware Version: Latest as of August 13
  3. Rooted or not: No
  4. Frequency of Occurrence: First time
  5. APP Name & APP Version (If your issue relates to the app):

I tried connecting my phone to the twin dock today and tried opening two apps, one above and one below. The games stopped loading and both screen stopped responding to touch. I can tell the screen is still running because animation on both screen works are still running, including the audio. I could however swipe up from the bottom of the screen to show the home button.

Since I could not do anything, I swiped up and I closed both the app. I went to search for another app on the search bar of the twin dock monitor however the keyboard did not appear. As such, I tried locking the phone with the twin dock lock button. My phone's screen turned off but the twin dock only dimmed.

After removing the phone from the twin dock, I stopped responding completely. The battery was 78% before it died. Tried power button, power button + Up, power button + down. Tried charging my phone, no heat on both phone and charger. Tried not charging my phone. No response at all.

The twin dock turns on when I connect the same charger.

It is noteworthy that my phone had been crashing and restarting randomly the past month. ROG logo, vibration and the metal slicing audio, before cutting into the OS.


========================================

This discussion has been closed.