Custom notification sound

john.kissanejohn.kissane Level 2
edited September 2020 in ZenFone 6

I wanted to use a custom notification sound but the phone won't allow me to select the file & gives the error message shown in the screenshot. The sound file

was originally an mp3 file but I converted it to ogg just in case the zenfone 6 didn't like mp3's. Any suggestions for how I can use the sound?

The error comes when I use the '+' button & then the file manager to select the file location in the Notifications folder on internal storage. Original file is also attached.


«1

Comments

  • RustylordRustylord Level 3
    edited December 2019

    If possible you could try using Google sounds, third party app, to check whether adding your own tone would work or not.

    Maybe it's because your SMS.mp3 is bit lengthy.

  • I want to use the same sms notification sound I had on my Zenfone 5 & before than an LG G4, why would it not work on the 6? It's 10 seconds long, don't think that's exactly lengthy!

  • Just use original sms.mp3, because ZF6 has no problems with mp3.

  • I tried the mp3 file first as mentioned then tried converting it to ogg but both were rejected.

  • Interesting, because I downloaded your sms.mp3 and it works without any problem on my ZF6 WW_17.1810.1910.73_0.

  • Thanks for testing it. Did you use the same method as I tried (in the screenshot) or am I just doing something wrong?

  • _jis__jis_ Level 5
    edited December 2019

    I downloaded the file and moved it from Download folder to Notifications folder in file manager.

    Then went to Settings / Sound & vibration / Notification sound / and clicked on sms - that's all.

  • Very strange I just did exactly that but the sms tone doesn't appear on the list of tones & if I try to select it via the file manager (or even from Google Drive) it gives me the error message shown in the screen shot.

    Not sure what else to try?

  • I had the same problem when trying to add an ogg file. One workaround is to use File manager app, select the file and set as "system sound" (More --> Set System Sound). Later change it in sound picker.

    That said for mp3 files they get added automatically in sound picker if these files are present in Ringtones/Notification folder. I am still on Android 9.

  • john.kissanejohn.kissane Level 2
    edited December 2019

    I tried that as well but the phone says setting system sound failed. The other file shown in the screenshot is my ringtone which works correctly. This used to work in Android 9 for me as well.


  • i tried it did work... set as default notification

  • Thanks for trying it but like mentioned it doesn't work for me. Error message as shown in the screen shot.

  • _jis__jis_ Level 5
    edited December 2019

    If even such a simple thing doesn't work, I wouldn't think a second and put the phone into a factory reset, because something is obviously completely wrong.

  • I considered that but can live without a custom notification sound just to avoid having to do all the set up again. Is anybody from ASUS able to comment on this?

  • wen you get next update better factory reset once.... it has solved multiple issues for me... last month...

  • When the next update arrives, do it this way:

    https://zentalk.asus.com/en/discussion/comment/32040#Comment_32040

    You can try at least these steps now if it helps:

    Clear cache to all apps.

    Restart in Safe mode.

    Restart again.


  • @john.kissane

    How did it end up? Did it help you?

  • Hi


    Downloaded the sms.mp3 , put it in /download/ and /notifications/


    Used "+" to add the custom ringtone and everything worked fine here.

    Trying to duplicate the issue but cannot - did you try to delete the file from your phone, and just download the same one you uploaded here? (Retrace the same steps we are).

  • Sorry for the delay, afraid that didn't help. However I did get it to work by copying the file into the notifications folder used by Slack (Android/media/com.Slack/Notifications) & it then appeared on the list of Notification sounds & worked.

    For reference I previously had it in the same folder where my custom ringtone lived in a folder called Notifications on internal storage.

    Thanks for all the suggestions.


  • @john.kissane

    Did you try "Clear storage" to "Media Storage" system app?

    Then restart phone and check again.

This discussion has been closed.