Asus ROG 2 phone delay on receiving Whatsapp notifications

ElizarElizar Level 1
edited September 2020 in ROG Phone 2

Hello, i'm Elizar. I just bought Asus ROG 2 phone a few days ago since i'm an active phone gamer which the phone exceed my expectations and i'm very satisfied with it. However, despite all of that the only problem i found kind of disturbing and inconvenient is that for some reason Asus ROG 2 has a delay problem on receiving notifications especially Whatsapp. I tend to use Whatsapp for communication with family, friends and reatives so that app is one of the most important thing to have in my phone. But ROG 2 delayed in receiving the messages. For example, my friend sent a text to me at 8.47pm today, the phone was with me all the time but when i opened Whatsapp at 9.39pm, the 8.47pm text from my friend finally popped out and the notification appeared. As you can see its really troubling me having my friends to wait for me to reply faster but the delay notification unable for me to do that... Please help me. Thank you.

Comments

  • There are couple of things you can try here:

    1. You need to check whether your Whatsapp is always running or not, follow below steps
      1. Settings --> Apps & Notifications --> Whatsapp --> Memory
    2. You need to make sure that your battery optimizer is not killing Whatsapp.
      1. Settings --> Apps & Notifications --> Whatsapp --> Battery --> Battery Optimization
        1. Add Whatsapp to the "not optimized" list, if not already present.
      2. Settings --> Apps & Notifications --> Whatsapp --> Battery --> Backgroud Restriction
        1. The setting should be "App can use battery in background"
    3. You need to make sure Whatsapp can access data all the time, try to just turn on "Background data", if your Whatsapp is still not working properly try to check "Unrestricted data access" as well.
      1. Settings --> Apps & Notifications --> Whatsapp --> Data Usage
    4. You need to make sure Whatsapp is allowed to auto start, go to the setting as mentioned below and select Whatsapp in order for it to auto start.
      1. Settings --> Battery --> PowerMaster--> Auto-start manager

    P.S. All of these methods will increase your battery drain, I would not suggest to perform all of them at once first try all of them one by one and check if your problem is resolved. If your issue is still not resolved, then I would suggest to perform all the steps together.

  • I already tried all of these. But unfortunately, the Whatsapp message notifications still has the delay problem until i open the app.

  • No way I added my WhatsApp under battery opt but still I receive notification

  • If your Whatsapp is always running and you have everything enabled then you should receive notification, but if you are still not receiving notifications then the last option would be check your network connection. If you are still not receiving notification then you are out of option. The only thing to do is hard reset your device yourself or through service center.

  • Yes mine too and it works, I faced the similar issue with Yahoo mail and found out that my Yahoo mail was not running all the time.

This discussion has been closed.