Notification panel broken after 31.1010.0410.61 update on Zenfone 8 Android 12

kwei88kwei88 Level 1
edited July 27 in ZenFone 8

After 31.1010.0410.61 update, my notification panel breaks if i do anything with it - toggle dark theme, swipe up to hide it, and it becomes black screen with white lines around the screen(See attached image). I

have to turn the screen on and off several times to get it back to normal. Please fix ASAP.



  • @kwei88 Clear cache files system-wide and reboot your device. I can't replicate this on any of our devices.

    Settings -> Advanced -> Mobile Manager -> Cleanup

  • frantsyfrantsy Level 2

    this happens if VPN is enabled. people also mentioned this in another thread "Phone goes crazy without reason"

    would @Gustav_ASUS please check again?

  • kwei88kwei88 Level 1
    edited May 19

    Just did and problem still persists :(

    I tap 'Scan cache', tap the 'Clean' button. Then I swipe down the notification panel to toggle dark theme, now I swipe up to hide it, and there's the dark screen again.

    Please help. Been going on like this for days...


  • kwei88kwei88 Level 1

    hmm I do use a VPN. Just turned it off. And looking good so far!!

  • frantsyfrantsy Level 2

    Do you have VPN enabled too? My problem happens only when VPN is enabled. So I suspect the phone does not display "... connected to ..." correctly. And this does not happen if the phone is rotated to landscape mode.

  • kwei88kwei88 Level 1

    Yeah looks like it's the VPN. I have turned it off. Now so far I can't replicate the issue anymore. Thank you!

  • frantsyfrantsy Level 2

    So @Gustav_ASUS, we can reproduce the problem when VPN is enabled. Would Asus plesae fix this in the next firmware? thanks.

  • That's an interesting turn of events. I'll send you instructions on how to generate a device log that I can pass on to the team. Check your Zentalk inbox.

  • frantsyfrantsy Level 2

    Got your instructions, but it's too much work for an end-user. Have you tried enabling VPN and see if you can replicate this problem first? At least a number of people in this forum experienced this since 31.1010.0410.61. And some have already posted screenshots like the one above. Please ask your development team to check and fix.

  • kwei88kwei88 Level 1

    @Gustav_ASUS I have done everything you asked for - log and video. Please check your messages.

  • dron39dron39 Level 2

    I have AdGuard (VPN) enabled and I didn't have that problem on .62 update and I don't have it now on .72 update.

  • th.beschth.besch Level 2

    Same problem here. Using NordVPN. Issue started after last update.

  • frantsyfrantsy Level 2

    which language is your phone using?

    i just tested switching to Chinese and the problem goes away. so the problem is with English (and maybe some others). @Gustav_ASUS please note, maybe that's why you can't reproduce the error

  • dron39dron39 Level 2

    RU language. But I don't remeber that problem also when I sometimes switched language to EN (US) for some apps.

  • OllandosOllandos Level 1
    edited May 20

    The problem is still there οn .72 when using Greek but it goes away when using English

  • frantsyfrantsy Level 2

    very strange then. in my case, the problem happens in Engish but goes away with Chinese

  • th.beschth.besch Level 2

    Same problem with German language. Just a guess, but I think the language is not necessarily the cause...

  • frantsyfrantsy Level 2

    Found a solution. Just set to a smaller font size then the problem is gone!!!

    So, apparently, the panel is having problem to display "Your prersonal profile is connected to xxxxxxxx" (where xxxxxxxx is your VPN name) if it is too long.. As I mentioned before, it works ok on landscape mode and sometimes in other languages, but people here is having different results with the same landguage. So I suspected it is related to the string length of this message.

    Would ASUS moderator @Gustav_ASUS help to follow up with your development team?? many thanks.

  • I've already report it in my thread but Asus mods just leave it without comment.

    Issue persist while VPN is connected. Easy to replicate by anyone.

    Shame that Asus act like they don't see any issue.

    Counting days when warranty will end. Zenfone can't be used normally as corporate phone.

    Shame on you Asus

  • th.beschth.besch Level 2


    Thank you! This worked for me too! Tomorrow I'll have to buy a new pair of glasses asus please fix this soon!

This discussion has been closed.