No Wi-Fi Calling setting

gargamel314gargamel314 Level 1
edited November 18 in ZenFone 9

Please tell us some basic information before asking for help:

  1. Model Name: ASUS ZenFone 9 256 GB/16GB
  2. Firmware Version:32.2040.2040.28
  3. Rooted or not: No
  4. Frequency of Occurrence: Continual
  5. APP Name & APP Version (If your issue relates to the app): The phone, settings

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I'm using Mint Mobile (T-Mobile MVNO), and Wi-fi calling doesn't work. The option doesn't even present itself in the menu. I find it very hard to believe that a product that markets itself as fully compatible with T-Mobile and its MVNO's doesn't support this basic feature. I was wondering if anyone has found a way to make this work, or is this just an early adoption bug?

Comments

  • cilsoecilsoe Level 1
    edited October 18

    Try entering the following in the phone app: #*#3642623344#*#

  • ArjanBArjanB Level 1

    T-Mobile "calling over wifi" works in my country, so it should only be a setting change for Asus.


    The other provider it does not in my country is KPN.

    Entering the code #*#3642623344#*# does bring up "calling over wifi" for the KPN, but it doesn't work

  • I literally cannot believe you have a mobile provider that is literally owned by the actor that plays deadpool.

  • bonjour . paramètres......appels , en bas activer appels wi fi non ?

  • réseau et internet ....... appels.......appels wi fi tout en bas

  • osstisosstis Level 1

    Wifi calling option is only available if your network provider and mobile contract offering to you.

    That's nothing to do with Asus Zenfone 9 as I have VOLTE and wifi calling both on with my UK Vodafone

  • osstisosstis Level 1

    UK Vodafone - WiFi Calling settings



  • Thank you everyone, I think I have what I need. What I figured out was by entering that code above (I'll enter it correctly here: * # * # 3642623344 # * # * [no spaces]), it makes the option available, and it will make it searchable in settings. I guess Mint (or T-Mobile, not sure which one) hasn't approved the ZF9 for Wi-Fi calling features yet (after speaking with Mint mobile tech support). According to ASUS, Wi-fi calling is "not available for unlocked devices," which is surprising, because I though the ZenFone 9 was basically an unlocked device.

    So if you enter that above code, it will allow you to turn on Wi-Fi calling until you reboot your phone, then the option will be unavailable again. So basically I put the code in my Google Keep notebook so I can just paste it into my dialer when I need the Wi-Fi calling. That's acceptable to me, but I do hope ASUS release a patch at some point to enable it, or Mint clears it for its network. I used an unlocked HTC U12+ for a long time with Wi-Fi calling enabled, it worked great, so I don't know how credible ASUS's response is.

    Oh and yes, Deadpool owns part of Mint. I pay a fraction of what I would pay at any other company, without all the drama that Verizon and AT&T gave me.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.