Access to EE network in UK (via MVNO)

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Rog Phone 3 (TenCent version with Global SIM)

Firmware version 18.0410.2108.158

Unrooted

Problem permanent

Hi. I'm in the UK have two SIMs in my phone: an O2 SIM which I use as a backup for calling and for data, and works perfectly. For my main calling SIM, I recently transferred from Three (which worked OK, but got too expensive on PAYG) to 1pMobile, which is an MVNO running off the EE network (formerly T-Mobile and now part of BT). I have tried everything - manually changing APN, resetting network, getting 1pMobile to refresh my SIM etc. etc., but I cannot get the ROG 3 to make a data connection with this SIM - it is only good for making and receiving calls and texts.

The 1pMobile SIM does work for data fine with my old Android 5 handset, so the problem is not the SIM. Has anyone else faced this or similar problems with EE or other MVNOs, and can suggest a solution? As I say, I can get data from the O2 SIM, but am on PAYG with that, and cannot be sure how long their good deal for this will last.

Tagged:

Comments

  • ayazayaz Level 1
    edited October 14

    Interesting, I use EE with mine and I get 4G / 5G with data and I also use Wi-fi calling.

    You tried doing a factory reset and trying again? I've had weird issues after a upgrade my data wasn't working but a mobile data off and on fixed it, a reboot didn't even fix it oddly.

  • Thanks very much for that, Ayaz. Are you using EE directly, or via 1pMobile? The problem may well lie with 1pMobile rather than EE. I've not tried the factory reset yet - but would certainly consider that if I can't use my second SIM for data. I'm sure that somewhere there is a simple setting that I need to tweak to get it all working.

  • ayazayaz Level 1

    EE UK directly, there is something in ADB that needs to be done to get WiFi calling working though.

Sign In or Register to comment.