(Fixed) Asus ROG Phone 3: Kunai 3 gamepad not working due to Android 11

Hello everyone,

I recently updated the firmware in the Asus ROG Phone 3 to Android 11.

Once attempting to use the Kunai 3 gamepad, it failed to work.

Cleaned the contacts, and troubleshooted the device.

After all attempts failed, I used the firmware downgrade back to Android 10 that is available on the Asus website.

Happy to share that this was the cause of the issue, and the accessory is now working again.

I am not surprised to be honest.

So, if anyone is having issues, I would suggest downgrading the firmware back to Android 10, until Asus releases an update that works.

Be aware that downgrading the firmware will format the phone, and erase the data.

Cheers!

Comments

  • That's not a fix man, that's still a problem. We shouldn't downgrade our firmware just because they didn't fix the problem it has. I just fixed my Kunai 3 Gamepad and i wouldn't want it to have issues again. Would your phone on Android 11 detect the gamepad via Bluetooth? Have you tried deleting / forgetting the current connection under Paired Devices and reconnect?

  • I also thought Android 11 had an issue with my Rog Kunai 3 not working as I experienced the same. But, then I noticed that Android 11 in general has issues with game-pads and apps that use "Accessibility" Options. So, if you have an app like an "Auto Clicker", "Button Mapper" or anything of the like that uses "Accessibility" will cause your controller to either not respond or buttons will not work.

    TO fix the issue you'll need to disable the "Accessibility" option of that app in question (Turn to OFF) and it will then allow your controller to work again.

    Once again this is an Android 11 issue not a ROG Phone 3 issue.

  • Yeah you're right, after searching around it does seem to be an Android 11 issue. And as you've mentioned, the fix is turning off app(s) enabled in Accessibility. What's strange was this issue actually popped up when I was trying to fix the button mapping issue i had with my emulators and i totally forgot about it! @moose4261 since you've already downgraded, might as well re-update and give it another go since the troubleshooting method is simple and straightforward

  • What kind of weird ass emulators do you use? All popular emulators have built in controller support, even the really weird ones.

  • The controller support is there, its just that most did not recognise my gamepad because of the Game Genie overlay. When i was searching ways to fix it, the Android 11 issue came out as well which led me to turn off the Game Genie. After that removing them from Game Genie everything worked. The virtual button mapping on Game Genie is more applicable to mobile gaming and not emulators

  • Okay i received the FOTA today and updated to Android 11 without any issues. As raised by @moose4261, the Kunai 3 Gamepad indeed stopped working however after disabling all apps enabled in the Accessibility setting, it worked again; both USB and Bluetooth mode. I tested on Genshin Impact (via Game Genie's virtual button mapping) and all the emulators i'm using, all works as before. Therefore as mentioned by @rogeriskira, the fix is to disable apps in the Accessibility settings as this is an Android 11 issue, not our firmware. The way i did it was by disabling all apps (such as Screenshot, Accessibility Menu, etc) and re-enabling them one by one until i am able to determine the specific app causing issues when enabled. So far, i have determined the Accessibility Menu (swipe two fingers up from the bottom to access the menu) will cause issues with the gamepad. Screenshot can still be enabled without issues.

  • Big thanks for reporting this. @jin_akira @rogeriskira @moose4261

    I'll pass it on to the devs along with the information in this thread. Please stick around in case I need your help with device logs. 😘

  • @jin_akira @rogeriskira @moose4261

    I've sent you device log instructions via PM. Would help us confirm the root cause for this issue, so please check it out.

  • edited September 13

    My issue is that my rog phone 3 isn't picking up the kunai 3 gamepad Bluetooth. It doesn't show up. But if I search for it on my cousins ipad, it's there. I'm not sure what I should do. Any ideas? (I already tried resetting network settings on my phone... Twice, but it still cannot find the kunai 3 gamepads Bluetooth)

Sign In or Register to comment.