Ghost touch after browsing specific URLs with Chrome or Brave

PmmaxPmmax Level 1
edited November 2020 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG Phone 2 (12GB RAM 512GB Storage) WW Version (From US)
  2. Firmware Version: 17.0240.2009.49
  3. Rooted or not: NO
  4. Frequency of Occurrence: Every Time
  5. APP Name & APP Version (If your issue relates to the app): Chrome or Brave browsers

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

CURRENT CONFIGURATION:

  • Glove Mode: Disabled
  • Air Triggers: Disabled
  • Refresh Rate: 120Hz

DESCRIPTION:

I have detected an issue that happens every time when I browse some specific URLs, using Chrome Browser or Brave Browser, for example the following URL:

https://www.jba.gr/es/Hebreos-10_23-29-35-39-si-pecamos-voluntariamente-si-alguno-retrocede.htm

After loading that URL in the browser and then scrolling up and down a few times quickly, the screen became unresponsive, even after closing the browser.

Attempts to use the phone after this is almost impossible, all apps fails because of the ghost touches.

Testing the screen using a "Touch Screen Test" app, I can see the ghost touch issue, since it detects at least 2 touches in different places even though I'm using only 1 finger.

The only way to fix is to restart the phone.

I have owned this phone for 1 year aprox and never experienced this issue, looks like software related.

What I don't understand is why after closing the browser (killing it on the task manager), the issue persist and the only workaround is to restart the phone.

HOW TO REPRODUCE:

  • Open Chrome Browser or Brave Browser
  • Navigate the URL: https://www.jba.gr/es/Hebreos-10_23-29-35-39-si-pecamos-voluntariamente-si-alguno-retrocede.htm
  • Scroll the screen up and down a few times quickly
  • Now the screen should start showing the issue

========================================

Could someone else test if this happens on other phone or it is just mine?

Thanks in advance,

Pablo

Comments

  • Me too. Exactly same hw and sw configs

  • This is certainly one of the more specific bugs I've seen here on Zentalk.

    Thanks for the detailed description. I'll check it out and get back to you.

  • Hi, thanks both for the quick response @Melqui , @Gustav_ASUS

    So I guess it is a software issue since @Melqui was able to reproduce.

    @Gustav_ASUS I will wait for your feedback.

    Best regards,

    Pablo.

  • @Pmmax

    I'm unable to reproduce this issue on my test device. I tested two versions of Chrome and different refresh rates, but no ghost touches in sight. I think the fastest way to get to the bottom of this is with a device log. I'm sending you instructions via PM.

  • MelquiMelqui Level 3
    edited October 2020

    @Gustav_ASUS Its intermittent. Sometimes occurs, sometimes not.

This discussion has been closed.