Zenfone Max Pro (M1) [ZB601KL] -not able to connect phone to PC for file transfer

bijoyroy95bijoyroy95 Level 1
edited November 2020 in ZenFone Max Pro Series
  1. Model Name: Zenfone Max Pro (M1) [ZB601KL]
  2. Firmware Version: PKQ1.WW_Phone-16.2017.2007.084-20200706
  3. Rooted or not:no
  4. Frequency of Occurrence:Since August, always

========================================

I am not able to connect the phone to my PC, for file transfer. It only charges. PC is not able to detect the phone, nor does the phone show the usual options of USB connection ( file transfer, charging, picture transfer etc).

I last connected to the PC in May. Haven't backed up any data since then and now am in a fix. Need to back up files to PC, to make space on phone. Please help.

Troubleshooting from my end:

Tried both official and other usb cables ( Belkin, Realme). All of them only provided charging.

Restarted phone, restarted PC, tried again. No success.

Tried connecting another phone to my PC, using official ASUS cable. Only charging, device not detected. So maybe issue with Asus cable also , so keeping that aside for now.

Tried connecting the other phone to my PC, using the Belkin USB cable. Success. Was able to get other phone detected and transfer files.

Taking this Belkin cable, tried connecting Asus phone to PC. Not detected, only charging.

Restarted Asus phone in Safe Mode, tried all cables I have. No success.

Came back to normal mode, tried all cables. No success.

Through the process, I toggled the phone USB preferences ( through developer options) from no data transfer, to file transfer, PTP but no success. The place where you would usually change the USB preferences, which lies outside dev options, in the normal settings, that doesn't even allow any changes.

Please help. Can't even go to official repair centre due to COVID-19.

Comments

  • İ used to have similar issue but in my case pc would detect phone but wouldn't show it. Anyway, i can't remember that well but i deleted a dll file in system32 that caused failure to install correct driver for it. İt was something mpt.dll or similar, search on the web for it, maybe you can find it.

  • Hi there, we'd request you to please visit the nearest ASUS service center for better assistance, kindly call first and then visit. Locate here : https://www.asus.com/in/support/Service-Center/India

  • hey bro.. i dont know if your problem is solved..

    but here what you can do..

    go to device manager..

    plug your device with any cable(data transfer supportive)

    now check which driver is shown in device manager..

    if it showing a android device , then right click..

    select update drivers

    then select update driver manually..

    select i have a disk

    now there are 2 options..

    google & something else driver

    select something else instead of google..

    then press update,finish whatever it is..

    hope might help

  • @qromodynmc

    Thanks for the reply. I looked into the dll option. It looked risky, messing around with the registry. Also, the phone isn't being registered at all. So problem might be different.

    @sayyedsharuk55

    Thank you for reply. Unfortunately, it's not showing up in device manager :(

  • Does computer make any sounds when you plug it in?

  • The phone has always connected to the PC via USB 2.0 ports, and there's no sound from the PC when I connect it. The USB 3.0 ports give the sound but the same error as in the past.

    The issue is that it used to be recognised and connected via the USB 2.0 ports atleast but it has stopped. Only charging takes place.

  • just do this thing then

    go to device manager interface

    plug device in.. and out several times..

    check for which driver showning..

    i am 100% sure that in top of the list .. an android device is shown whenever plugged in..

    of it is .. then try my process again...

  • hi,

    I am also facing the same issue. It is not showing in the Device Manager.

This discussion has been closed.