cancel
Showing results for 
Search instead for 
Did you mean: 

No mobile data while the WiFi is on

Roystoys
Zen Master III
Please tell us some basic information before asking for help:
Model Name: zenfone 7
Firmware Version: latest
Rooted or not:not
Frequency of Occurrence: all the time
APP Name & APP Version (If your issue relates to the app):
In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.
========================================
Since the last update ( I believe) I have trouble using mobile data while leaving WiFi on .
I am unable to access mobile data while the WiFi is enabled (and not connected to anything)
I have tried resetting my phone (THREE TIMES by FACTORY RESET) and it works for a while then just doesn't work at all.

8 REPLIES 8

slimghost
Rising Star I
Roystoys

Please tell us some basic information before asking for help:

  1. Model Name: zenfone 7
  2. Firmware Version: latest
  3. Rooted or not:not
  4. Frequency of Occurrence: all the time
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Since the last update ( I believe) I have trouble using mobile data while leaving WiFi on .

I am unable to access mobile data while the WiFi is enabled (and not connected to anything)

I have tried resetting my phone (THREE TIMES ) and it works for a while then just doesn't work at all.


No mobile data while the WiFi is on
Select "mobile data always active" from the Developer Options menu

Roystoys
Zen Master III
slimghost

https://zentalk.asus.com/en/discussion/55420/no-mobile-data-while-the-wifi-is-on

Select "mobile data always active" from the Developer Options menu


View post
I did that, ended up having to do a hard reset. Problem gone,, for now,,we will see how long it lasts for this time.
Yes I said this time as it's the second time in a week I have had to factory reset my phone to fix this bug.
It has only happened since I started using a 5 G card so not sure if it's that or the last update

slimghost
Rising Star I
Roystoys

https://zentalk.asus.com/en/discussion/comment/195451#Comment_195451

I did that, ended up having to do a hard reset. Problem gone,, for now,,we will see how long it lasts for this time.

Yes I said this time as it's the second time in a week I have had to factory reset my phone to fix this bug.

It has only happened since I started using a 5 G card so not sure if it's that or the last update


View post
even a bug may happens, but I will rather think that the network provider (and the settings) may be involved. As you sayed, all of these are happening since you've placed that 5G card, probably it is not a simple coincidence. Anyways, there is a reasons for such of things to be logged, ny Asus in this case , with the user consent. As the settings, or SIm card or whatever can be so different for each every user, better get a representative to analyze the logs. You may be right, or can be something different. Cheers!

Roystoys
Zen Master III
slimghost

https://zentalk.asus.com/en/discussion/comment/195685#Comment_195685

even a bug may happens, but I will rather think that the network provider (and the settings) may be involved. As you sayed, all of these are happening since you've placed that 5G card, probably it is not a simple coincidence. Anyways, there is a reasons for such of things to be logged, ny Asus in this case , with the user consent. As the settings, or SIm card or whatever can be so different for each every user, better get a representative to analyze the logs. You may be right, or can be something different. Cheers!


View post
Thanks I will 👍