cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth broken since update

Roystoys
Zen Master III
Since the last update my Bluetooth is a nightmare,no one can hear me properly.
I have it connected to a 2019 Toyota HiAce,s multi media unit and has always been crystal clear now I can hear them but they can't hear me properly.
Has anyone else come across this bug ?
Any ideas on a fix that doesn't involve a full reset?
6 ACCEPTED SOLUTIONS

Roystoys
Zen Master III
Aryan202

https://zentalk.asus.com/en/discussion/56099/211213-zenfone-7-pro-7-ww-30-41-69-140

Hopefully your bug gets sorted out after updating to this version

ota should be out soon


View post
God they are coming thick and fast lately, what's this make three updates in as many weeks?
I have managed, after three hard resets, to get my phone working properly again I don't know if I trust another update

View solution in original post

Roystoys
Zen Master III
Finally got to check with another phone. The other phone ( Nokia G10) works fine,at the same time this ZenFone 7 doesn't work.
Time to put a claim in

View solution in original post

Danishblunt
Hall of Fame I
Roystoys

https://zentalk.asus.com/en/discussion/comment/199822#Comment_199822

I think you hit it on the head. I got the 1+pro and if I leave the battery saver on I get the issue, but turn it off and like magic it clears up.

I still can't be 100% positive as I am still on holiday so not using my van much but it seems to be it

PS how did you get to a battery bug you clever person?


View post
Because bluetooth is a mess. I know that if bluetooth uses low power mode, the data transfer becomes very restricted and slow. If something works fine when something is on but works badly when something is on standby and is related to bluetooth then it's very likely related to LE mode, which makes sense as the bluetooth modules do suck quite a ton of battery and it wouldnt make much sense to leave it on stock mode as it would drain a ton of battery in standby, which as I believe the OP actually does.
Maybe ASUS could make a feature where it detects a headset or similair is being used (not connected, but actually used) and then turns of the LE mode off bluetooth temporarily.

View solution in original post

Danishblunt
Hall of Fame I
Roystoys

Well my dalliance with OnePlus didn't last long. Great phone but they really stuffed up A12 bugs,bugs bugs and some more bugs. On A11 it was great so I suppose I could have rolled back to it but I only had so much time to return it for a refund. To top it off I still had the same issue with android auto and Bluetooth with the OnePlus but I think ( I know famous last words) but this time I have my fingers and toes crossed.

I have suspected it may be the Vodafone Sim card so I purchased a new Telstra prepaid 5G Sim card and so far it is like new again. The Telstra prepaid card is only valid for a month so I have that long to test it and see what happens. The Vodafone Sim card is a 12 month Sim and I am only a little less than 2 months into it , just about when my nightmare problem started, so I suppose I will keep it in number 2 slot and if the problem really is gone I will pay for a year on the Telstra prepaid card and keep that one in number 1 slot.

I can see a light at the end of this tunnel I just hope it's not a 🚆 Train 🤣


View post
Same with the entire A11 on 7T, it was quite a nightmare as well, bug fiesta. ASUS got a way better grip on that, less bloated, less things to break.
As of now, I would defnitely wait and see whats going on with the ZF9. ASUS taking this long is extremely good news, phones with 8 gen1 pushed out and are not exacly impressive, gaming phones also out in feb and we still haven't heard from ASUS yet which means this time quality control is being taken very serious, they seem to have learned that rushing phones will only cause lots and lots of trouble and money in the long run (see zf8 non flip and Rog5 problems/bricks)

View solution in original post

Roystoys
Zen Master III
Danishblunt

https://zentalk.asus.com/en/discussion/comment/199740#Comment_199740

you can attempt it, if that's the case then it's a battery saving bug.


View post
Danishblunt

https://zentalk.asus.com/en/discussion/comment/199740#Comment_199740

you can attempt it, if that's the case then it's a battery saving bug.


View post
Danishblunt

https://zentalk.asus.com/en/discussion/comment/199740#Comment_199740

you can attempt it, if that's the case then it's a battery saving bug.


View post
I don't know if this is possible but can a bad data cable corrupt android auto in my van ?
I am asking because I recently purchased a high quality Anker cable for my van to connect my wireless AAWireless dongle to my van and now it works great on either Sim card.

If that is possible I perhaps should have bought one ages ago.

View solution in original post

Roystoys
Zen Master III
Well I think I finally worked out what the problem was,I know I have said this before but this fix has lasted a few weeks now, all it was was a corrupt data cable,is this possible?? I purchased a high quality Anker cable and like that everything works again. I don't really understand why but it seems that when I connected my wireless android auto dongle with the bad cable to my van it would cause my vans multi media to play up including Bluetooth calls made after disconnecting it . Man talk about touchy ,it nearly drove me up the bloody wall . I knew I would get there in the end 😅

View solution in original post

62 REPLIES 62

topolov
Rising Star II
Roystoys

https://zentalk.asus.com/en/discussion/comment/197604#Comment_197604

What does the CPU core do ? I think it has something to do with the speed of your phone but I'm not sure


View post
Start with this to understand what CPU is https://en.wikipedia.org/wiki/Central_processing_unit
Then go here to understand why there are different types of cores in mobile CPUs https://en.wikipedia.org/wiki/ARM_big.LITTLE

Danishblunt
Hall of Fame I
Roystoys

Since the last update my Bluetooth is a nightmare,no one can hear me properly.

I have it connected to a 2019 Toyota HiAce,s multi media unit and has always been crystal clear now I can hear them but they can't hear me properly.

Has anyone else come across this bug ?

Any ideas on a fix that doesn't involve a full reset?


Bluetooth broken since update
This likely happens due to bad choice of bluetooth codec. It's not really a bug, it's just android being terrible at auto selecting the codec, hell this might even be your cars doing. It's best to select the proper codec, I would refrain from using low latency as thats the one you probably are using. Try to manually select the aptx HD codec and you should have to good ol call quality back. Bluetooth itself is a little fiddly.

Roystoys
Zen Master III
topolov

https://zentalk.asus.com/en/discussion/comment/197635#Comment_197635

Start with this to understand what CPU is https://en.wikipedia.org/wiki/Central_processing_unit

Then go here to understand why there are different types of cores in mobile CPUs https://en.wikipedia.org/wiki/ARM_big.LITTLE


View post
Ok cool I'll check it out when I get home from work

Roystoys
Zen Master III
Danishblunt

https://zentalk.asus.com/en/discussion/55999/bluetooth-broken-since-update

This likely happens due to bad choice of bluetooth codec. It's not really a bug, it's just android being terrible at auto selecting the codec, hell this might even be your cars doing. It's best to select the proper codec, I would refrain from using low latency as thats the one you probably are using. Try to manually select the aptx HD codec and you should have to good ol call quality back. Bluetooth itself is a little fiddly.


View post
How do I chose a particular one?

Danishblunt
Hall of Fame I
Roystoys

https://zentalk.asus.com/en/discussion/comment/197668#Comment_197668

How do I chose a particular one?


View post
Go to the settings menu and click “About phone”
Scroll down to the bottom where you see “Build number”
Tap it seven (7) times. Android developer settings are now enabled
Go to the settings menu again and click System->Developer options->Bluetooth Audio Codec
Choose your audio codec of preference