cancel
Showing results for 
Search instead for 
Did you mean: 

Google lens can't accessible... Any suggestions?

spmsenthilkumar
Star III
Whenever I try to access Google lens from camera interface, it shows Google lens not available, please sign in to your account.
If try to access Google lens app, it shows , thanks for updating. Lens will be available soon. Please try again later.
If I try to select photos or any images from Google photos app and tried lens option, it shows, something went wrong. Google lens not available.

Please suggest, whether google lens really not support or unavailable for 6Z or any other settings to fix.
Asus 6Z of WW firmware version.
SFT5VTISENRZ.jpg
297NS1QBT14V.jpg
NFJPX5J5O11W.jpg

PS: Google lens app not disabled, all permissions granted, of course signed into Google account (it's Android device right?)
1 ACCEPTED SOLUTION

mastervishikh
Rising Star I
Also make sure that the Google app is enabled permission granted.
Hold the home button and let Google assistant open. There select the lens icon and accept their terms and conditions and check if you are able to access now or not.

View solution in original post

12 REPLIES 12

spmsenthilkumar
Star III
_jis_

https://zentalk.asus.com/en/discussion/comment/82281#Comment_82281

So it was the fault of the user who disabled an important system application. Do I understand that correctly?


View post
It's your fault to judge other people, what they want or don't?
I clearly knows your intention of this comment. You cannot tolerate something you don't know , other can provide.
And moreover, is anywhere mentioned Google app is very important. It's purely a user choice to choose what to use or don't.
FYI, earlier I used Nokia 8, in that mobile also I disabled Google app and used lens app without any problem.

_jis_
Zen Master III
I clearly knows your intention of this comment. You cannot tolerate something you don't know , other can provide.
No, it's your fault to falsely judge other people. Please, don't be evil. I will ignore it anyway.
How can anyone advise you to enable a system application when you claim to have done a factory reset? That wouldn't make sense. In order to get that advice, someone must have overlooked your claim that you already reset your phone...
Tried everything.... Even did factory reset
I appreciate that you had the courage to write down how you fixed it, which is very positive, but you refuse to accept it as your mistake.
Ok, peace 🙂

CH_ASUS
Community Legend II
While unexpected behavior from your devices surely are annoying - please keep a friendly tone to eachother.

For this particular issue, thank you @mastervishikh for your assistance.

In a default state - if you have never signed up for Google Lens terms of service, upon first start our Camera app will notice you to sign in to your Google account. What it perhaps could spend a few extra rows is to add in 'Lens' (as that may or may not be immediately obvious).
Upon entering the Lens app for the first time, there is a Google popup asking for approving the terms of service - after which pressing OK, 'Google' will ask for permissions to access camera - as it should.
It is likely, at some point, in this step or manually prior to this, where you have denied Google access to your camera.
The prompts on why Google Lens cannot access the camera, is entirely up to Google, Lens is not an Asus app and we cannot change its behavior.

In the end, at least the problem has been remedied. The root cause is not a bug but rather a manual system permission rejection made. Thread closed.

Thank you!