cancel
Showing results for 
Search instead for 
Did you mean: 

Warranty no more

roice_mark
Star I
Model: ZE620KL
RAM: 6G
Firmware/APP Version: 9
Frequency of Occurrence: All the time
Rooted: No
APP Name:

As I check for other problems, I notice that alot of phones is eperiencing the same as mine. Me and my brother bought the same phone and we got the same problem, i am very dissapointed because I like this phone very much and I am very fond of it. As i check my phone it does not have any signal and i do not know why, I am seeking for answers and solution for this because as I read the problem keeps returning after they get it from customer service, I do not want to waste money to repair it if it will come back. I hope i can get an immediate action about this.
4 REPLIES 4

Y_ASUS
Zen Master I
Hi roice.mark, We would suggest that you try: (1.) Settings > Network & internet > SIM card> Disable and enable the SIM card (2.) Settings> Network & internet > Mobile network > Preferred network type> choose "2G/3G/4G" again. (3.) Power off your phone > reinsert sim card > turn on the phone (4.) Turn on airplane mode > wait for 3 seconds > then turn it off. (5.) Try using another sim card by a different operator (6.) Try resetting the network settings: Settings > System > Reset options > Reset WiFi, mobile & Bluetooth) If this problem still appears, what we would advise is that you have the unit sent in for an assessment and servicing where necessary. Sorry for any inconvenience this may cause. The link below will help in finding your local service center: https://www.asus.com/support/Service-Center-All-Countries/ Please also check your PM for a message I have sent you. Thanks for your help 🙂

snizams
Star III
Hi, I faced the same issue yesterday. This was the second time, I am facing it. Tried rebooting multiple times without any luck. Changed to Aeroplane Mode, No luck Removed SIM tray and reinserted, No luck Later removed both the SIM cards and insert a different one. Then it detected it. Now removed that SIM and inserted the original ones. It worked. This solution worked for me in the last two times when I face this issue

Y_ASUS
Zen Master I
snizams posted on 2019/11/25 12:25 Hi, I faced the same issue yesterday. This was the second time, I am facing it. Tried rebooting mul ...
Hi snizams, In that case, we would suggest that you have the unit sent in for an assessment and servicing where necessary. The link below will help in finding your local service center: https://www.asus.com/support/Service-Center-All-Countries/ Please also check your PM for a message I have sent you. Thanks for your help 🙂

wai_hon_leong
Star I
If you don't want to waste money, don't send it to service.