cancel
Showing results for 
Search instead for 
Did you mean: 

High temperature / CPU usage / battery drain on 2009.47

jasonwch
Rising Star II
Please tell us some basic information before asking for help:
Model Name:
Firmware Version:
Rooted or not:
Frequency of Occurrence:
APP Name & APP Version (If your issue relates to the app):
In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.
========================================
As many posted on the forum. I and everyone have similar issue. (This is already upgraded for whole night and a full charge)
CPU also peak at 2.84/2.96 as from Armoury Crate even didn't do anything
Temperature goes high
Battery drain quickly
"Android System" also taking all battery usage from Battery page
What I observed:
From running processes, "Google Play Service" always show up, which not the case in old firmware
What I've tried to fix:
Wipe data (all data not just cache) for Google Play service and Armoury Crate. After cleaned, seems the CPU back to 826Hz, but after I restart the device, it go back to 2.84/2.96 all the time
There may be something wrong on this?

266 REPLIES 266

jasonwch
Rising Star II
seems not related to FOTAservice.
the CPU is not spiking for an hour, the just now i check and update apps from Playstore. The CPU spikes again

Osmak
Star III
screenshot-20200924-083526798-7e2.jpg


No issues in my phone...I think u all need to purchase gaming phones from next time as you all clearly have no idea about x mode..turn it off and CPU usage will go down...next time before complaining read rog 2 manual

jasonwch
Rising Star II
Osmak

screenshot-20200924-083526798-7e2.jpg

No issues in my phone...I think u all need to purchase gaming phones from next time as you all clearly have no idea about x mode..turn it off and CPU usage will go down...next time before complaining read rog 2 manual


View post
first, i didnt turn on X mode
second, well, you didn't update to 2009.47 yet (Armoury Crate changed its interface) or ur Tecent version is not the same as our WW version

jasonwch
Rising Star II
Updated Google Playstore 21.9.50 from APKMIRROR. Restarted the phone, CPU no spiking. Did once "Check for update" from Playstore but DIDN'T update the app pending, still no spiking.
I will check again after an hour, if still no spiking, will try to update that pending app and see if CPU spikes again

Osmak
Star III
jasonwch

https://zentalk.asus.com/en/discussion/comment/116948#Comment_116948

first, i didnt turn on X mode

second, well, you didn't update to 2009.47 yet (Armoury Crate changed its interface) or ur Tecent version is not the same as our WW version


View post
Yes I have not updated yet but even if I have updated I would not get any problems coz I know how to use gaming phone 😉