cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Phone not charging with original charger

houdeks77
Star I
Hi all,
My Rog Phone 2 does not charge with original charger. It shows the hypercharge icon but does not charge. I tried different cable ... no luck. Different charger works fine, original charger when used with different device works as well. It seems to be a sw issue to me.
How to resolve the issue?
Standa
21 REPLIES 21

zeruel_tenshi
Rising Star II
Are you on A10? Is yes, did this happen after you upgraded? Anything that you've done so far on the software side of things? Does the sise port work? More basic information would help remove variables and pin point a possible cause be it software or hardware.

houdeks77
Star I
It started after last update in Feb, am not on A10, side port is the same. The two thunderbolts and cold not charging phone, it does not matter if phone is on or off. Original cable with different charger is fine. It only happens when I connect original charger.

zeruel_tenshi
Rising Star II
That's odd I don't think there was ever an update for A9 released last February. Anyway the issue might be the charger brick itself.

Anders_ASUS
Hall of Fame III
houdeks77

Hi all,

My Rog Phone 2 does not charge with original charger. It shows the hypercharge icon but does not charge. I tried different cable ... no luck. Different charger works fine, original charger when used with different device works as well. It seems to be a sw issue to me.

How to resolve the issue?

Standa


Asus Rog Phone not charging with original charger
Have your charger or phone been in a cold environment?
What happens if you restart your phone while the charger is connected?
Same result on both ports?
What happens if you have the aerocooler in between?