cancel
Showing results for 
Search instead for 
Did you mean: 

ROG 5 Ultimate battery drops to 0% in an instance. Like, KABOOM! kind of drop.

rp115640
Star III
Please tell us some basic information before asking for help:
Model Name: ROG Phone 5 Ultimate
Firmware Version: 18.0840.2112.210
Rooted or not: Not rooted
Frequency of Occurrence: 2 times so far
APP Name & APP Version (If your issue relates to the app): NA
In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.
========================================
Hello,
There's something super weird with my phone. After the vibration stop working, which I choose to ignore it for now. The battery can drop to 0% in a blink of an eye. I'm not exaggerating. Take a look at these screenshots on 2 separate occasion.
screenshot-20220201-203703187-1.jpg
screenshot-20220205-174825697-1.jpg
Any idea what is causing this?
Thanks in advance.
1 ACCEPTED SOLUTION

Danishblunt
Hall of Fame I
looks like miscalibrated battery, let it charge to 100%, let it drain to 0% then charge it back to 100%, after that the batteries should be recalibrated again.

View solution in original post

8 REPLIES 8

Danishblunt
Hall of Fame I
looks like miscalibrated battery, let it charge to 100%, let it drain to 0% then charge it back to 100%, after that the batteries should be recalibrated again.

rp115640
Star III
Danishblunt

looks like miscalibrated battery, let it charge to 100%, let it drain to 0% then charge it back to 100%, after that the batteries should be recalibrated again.


View post
Oh. Alright, I'll give this a try.
Hope it's just a miscalibration as you suggest.
Thanks for the information and advise.

Gustav_ASUS
Community Legend III
@rp115640 Have you tried to recalibrate your battery yet? if so, what was the result?

rp115640
Star III
Gustav_ASUS

@rp115640 Have you tried to recalibrate your battery yet? if so, what was the result?


View post
Yes, I've tried it. Here's my observation.
I let the battery depleted totally. Then I start charging it, and turn on the phone the moment it has enough juice. I let it charge fully, but it stuck at 99%. So I just stop charging and use as per normal to observe, and the same issue of KABOOM battery drop happen.
For my second attempt. I try charging the phone fully without turning the device on. This time it manage to get to 100%. And so far, the drastic battery drop seems to be rectified.
But now I cannot turn on my WIFI. It's like a queue of faults are waiting to greet me. Looks like I got to visit the service center anyway. I was trying to avoid this action until I've gotten ROG 6... Sigh...