cancel
Showing results for 
Search instead for 
Did you mean: 

ZenFone 3 (ZE520KL) Android 8 prevents me to install enterprise blackberry

Zack_2022_ZH
Star I
ZenFone 3 (ZE520KL)
Android Version 8.0
We are in 2022 and I tried to install Blackberry on my mobile and it cannot installed due to android 8.0 installed on the device(smartphone ZE520KL) . The application (which is very popular) needs 9 version or higher. can you please put a little effort to provide a more recent version of OS? (last is from 2018).
further note: it seems that such obsolete SO 8.0 doesn't ensure the proper security level and it would be nice to get more safety and data protection and virus protection on your devices. It is a very key point.
You should allow to your users to have the highest level of protection and install applications and to not make your own devices obsolete.
Thanks and Regards



0 REPLIES 0