cancel
Showing results for 
Search instead for 
Did you mean: 

X13 Flow with Mobile XG - Laptop doesn't recognise Mobile XG

infradeaad
Star I
System: System Model: ROG Flow X13 GV301QH_GV301QH with GC31 XG Mobile
I have the above model which I've had issues with since I've purchased it. Every time I disconnect the XG Mobile, I have to reinstall Armoury Crate to get the XG mobile to connect. However, this time, it won't detect at all. The Armory Crate switcher app does no open when I plug the XG Mobile in.
USB is being passed through, the XG Mobile is powered.
I've used the Armoury Crate uninstall tool, then installed the latest version of Armoury Crate.
I've used the Bios update tool to go to 410.
I've downloaded the latest drivers from Asus:
image.png
Just can't get it to work and it's so frustrating.
Can someone from Asus help please?
Thanks.

2 REPLIES 2

GEEK_ASUS
Rising Star II
Hi there,
Please check below steps to see XG Mobile can be detected or not.
Q3:  Why is my laptop showing the message "XG Mobile not detected"?
A3:  If the ROG XG Mobile connector was not correctly disconnected in sleep mode or while shutting down, please follow the directions to connect ROG XG Mobile connector again. Then click "Y" button to boot laptop safely, to avoid unsaved data loss.


Thank you.

ASUS_Bot
Rising Star I
Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.