cancel
Showing results for 
Search instead for 
Did you mean: 

No signal on usb-c/display port both on windows and linux

wrutek
Star I
System: windows11/ubuntu20.04/ubuntu21.10
Battery or AC: both
Model: rog flow x13 gv301qe-K5110T
Frequency of occurrence: for the first time it worked now it doesn't
Reset OS:
Screenshot or video:
========================
Detailed description:

Hi,
I'm very happy of my new laptop however I do have a concern that my displays ports are not working (both left and right).
Windows is telling me that my laptop can not support display port and ubuntu shows
`DisplayPort 0: not connected`
`DisplayPort 1: not connected`

I tried with asusctl, supergfxctl with different nvidia drivers and nouveau.

I'll be happy for some help on this, because beside that this laptop is something that I was looking for for a long time and I wouldn't like to give it back.
3 REPLIES 3

Blake_ASUS
Community Legend II
Hi there,
When it first worked, are you using Win10 from factory? was it before you load any update?
If you replug the monitor or reboot the device, does the display work?
If you connect the monitor to the XG mobile instead of the type C port on the laptop, does it work?
Thank you.

wrutek
Star I
Thank you for your response @Blake_ASUS
>When it first worked, are you using Win10 from factory? was it before you load any update?
It was on win10 from factory. Then I made a dual boot with ubuntu and there i worked too (until the first reboot).
After some updates on windows it was working too for a brief moment but stopped.

>If you replug the monitor or reboot the device, does the display work?
Unfortunately no. Nothing works right now, nor repluging nor reboots

>If you connect the monitor to the XG mobile instead of the type C port on the laptop, does it work?
Only if I activate eGPU (which is possible only on windows right now, but I believe this is different problem). If I deactivate eGPU with connected XG mobile, external monitor do not work.

Blake_ASUS
Community Legend II
Hi there,
Thank you so much for the information.
I have reported your case.
Please kindly provide your product SN in the PM I sent you.