Showing results for 
Search instead for 
Did you mean: 

Fast Charging not working after update

Star I
Model: ZE620KL
Firmware/APP Version: Latest
Frequency of Occurrence: Most of the time
Rooted: No
APP Name: Battery

After I have update my phone to the latest firmware I have noticed that fast charging rarely works. Tried changing settings on Battery care, tried rebooting the phone, tried to factory reset the phone but to avail Fast charging does not work. Please help. Charging now takes 3 hours before charging only takes about an hour or so.

Star I
Still waiting for the answer to this problem. Why is fast charging not working properly?

Zen Master I
Hi intela4tech, Is your firmware version WW-16.0615.2002.120? Are you using the original adapter? Have you tried with different chargers or cables? After inserting the cable, "fast charging" may not appear instantly. Please wait for a while and check if "fast charging" appears on the lock screen. Thank you 🙂

Star III
Last edited by Xern on 2020/3/27 02:07 Here's my answer, stop using the original cable. Although mine wasn't because of an update just suddenly happened but I also couldn't fast charge anymore, if you have anyone in your family or have another cable that's capable of fast charge try using it and see if it'll fast charge. If it does then it means the cable is broken, like what happened to mine.

I just faced this problem two days ago.
And I still waiting for the solution.
Maybe it BUG on Android 10