Default Avatar

jsky

Member

jskyMember Level 1

About

Username
jsky
Joined
Visits
4
Last Active
Roles
Member
Points
1
Badges
1

Badges

First Comment

Comments

  • jsky
    Hi, my Google account comes from a region that supports Tidal and I have a valid Tidal subscription. I tried installing older versions of Tidal (v2.46.0.1042.3635) and it works. However I cannot update to latest version (2.47) anymore as it is showing the "this app isn't compatible with your device anymore. Contact the…
  • jsky
    I already have Tidal account subscription running on 3 other phones: Huawei M20x, LG V60 & Sony 1 II. Tried to side load the apk from Sony and it cannot install also. (BTW I also posted in the Chinese language section in case someone there knows the solution) .