ystem update failed (3) unknown error system restored to previous configuration



  • Oh my god your sorry worked now we can update our phone and now we don't even have to touch our phones it is doing everything we want by reading the thoughts coming in our mind . thank you asus

  • Y_ASUSY_ASUS mod
    edited May 2020

    Hi all,

    If you're on WW-16.2017.2002.061 or WW-16.2017.2004.063, and would like to update to Android 10 WW-17.2017.1911.407, we suggest that you first downgrade to WW-16.2017.1912.060, then you can successfully update to Android 10. 

    The downgrade file and instructions could be found under "MaxProM1_downgrade_to_9" in the link below. 


    Thank you and have a nice day🙂

  • I'm with the same problem and I did the procedure of dowgrading from 10 to 9, with the right firmware from asus site. Now I'm in 0.60 and have the problem when upgrading to Beta 2.

  • Thank you for the sugestion, but I did this procedure using "MaxProM1_downgrade_to_9". It gave me .60, but I'm unable to go to .424

    The 424 description says: "This version is only for WW SKU device that with Android 9 OS WW-16.2017.1910.059 & WW-16.2017.1912.060 version."

    But it is not working on .60 version...

  • Hi wesley.b.peres & all,

    Sorry, if you would like to update to Android 10 WW-17.2017.2004.424, you can update from WW-16.2017.2004.063 or WW-17.2017.1911.407.

    The relevant team is adjusting the description under WW-17.2017.2004.424. It takes some time for the system to renew the website.

    Thank you.

  • downloaded it from mobile update failed downloaded it from pc then tried still update failed whats the problem of this update can any one tell me plz

    my build nuber ww-16.2017.2005.082

  • Hi syedifty

    Thank you for your asking. The issue of WW-16.2017.2007.084 is now under investigating, please try auto update first. If you still like to perform manual update, kindly try it again on Saturday.

  • I have also the same problem regarding update in my Max Pro M2. My phone build no. is- WW_Phone-15.2016.1902.192-20190226.

    Please Please Help Me .....

  • Hi Banerjee

    Thank you for your asking. Are you trying to upgrade WW-16.2017.1903.064?

    First, please backup your data and perform "the Factory Reset" first. Settings>System>Advanced>Reset options>Erase all data(factory reset)

    Second, to avoid the incomplete file downloading, please re-download the file again from PC and put the file into the root directory (aka the outermost place) of internal storage of the phone. Reboot. Then tap the System Update notification.

    Have you ever rooted or unlocked your device? If you still can not update your firmware, please provide me a video of your performing process.

This discussion has been closed.