ASUS Face Unlock Service keeps stopping

ASUS_TopFanASUS_TopFan Level 1
edited September 2020 in ZenFone 5 Series

I can't register my face data since I updated my ASUS Zenfone 5 (ZE620KL) to Android 10 beta 3. I already downgraded my phone to android 9, updated it again to its latest android 9 firmware version but still my face unlock still don't work. Please help me fix this problem.


  • Hi ASUS_TopFan

    Thank you for your asking. I've tried my ZE620KL with the same firmware V16.0615.2005.130 and V17.0615.2005.25, yet face unlock service works properly. Kindly try some stay-at-home troubleshooting tips below:

    A. Tap App info of your screenshot>Advanced>Battery>Background restriction, make sure *restrict is removed

    B. Please try to enter "Safe Mode". If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    C. Also, please try "the Factory Reset" 

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

  • Thank you! I already fixed the problem. I did your troubleshooting tips A and B. I entered to Safe Mode and tried to register my face but it seems that troubleshooting tip A is more effective. There's no restriction in battery. But I clear the storage and my face unlock already works fine!

  • Hi ASUS_TopFan

    I'm glad to hear that. Cheers :)

This discussion has been closed.