USB preference not working

lankeshsawant3lankeshsawant3 Level 1
edited September 2020 in ZenFone 5 Series

I am unable to connect to any laptop/pc as my usb preference is not working

It's showing greyed out

Model is Asus 5z

Does anyone have a solution for this??


  • ammzulammzul Level 2
    1. Change The Cable & See, Preferably Use The Asus Supplied Cable Or Any Good Quality Cable.
    2. Change The USB Port Of The Laptop And See.
    3. Change The Laptop / Desktop And See.
    4. Install The Asus Drivers First And See.
    5. Is Your Windows In Admin Account Or Non Admin Account?
  • The cable is the original cable which I got from the box

    Already tried changing the ports

    Also tried on different pc

    I have the latest drivers

    Windows is probably non admin but that's not the issue I also tried connecting a OTG it didn't work and the OTG is working fine on other devices

    I think the problem arose after last update ( not this month) because it was connecting fine before

    The problem is in the settings I think

  • Hi what's your firmware version?

    If you have tried all the troubleshooting as mentioned above then probably you can visit your nearest service center.

  • RitaRita Level 1

    1. A OS update appeared to have disabled USB data transfers.

      Developer Options>Default USB configuration>no data transfers.  Select the file transfer.  Restart phone.

    2. This is NOT a physical issue.  There is something wrong in the update.

  • deadPOOldeadPOOl Level 1
    edited June 2020

    Same issue here been finding a solution for a month now nothing happens , after update to android 10 beta 2, usb preference greyed out tried to change it to transfer file on developer option still nothing happens, factory reset downgrade to android 9 still the issue remains this is the biggest pain in the ass bug ever I know that there are risk for trying beta updates but WTF asus why this? how can we fix our devices if we can't connect it to our PC's?

  • I have the same poblem and I sent him to service center but nothing has changed. I had this problem after the first time the phone came back from the service center and they never managed to fix it. so dissappointed from asus sopport and service center.

  • RitaRita Level 1

    Buy a new USB cable that can transfer data. The cable I originally used was only good for charging. UGREEN, AUKEY USB Type C Cable to USB 3.0 A.

    1. Enable developer mode by going into Settings > System About Phone > Build number and tapping a few times (5-7 I think!)

    2. Click back and then select Advanced > Developer Options

    3. Scoll down the menu until you see "Default USB configuration".

    4. Tap and then select the option you require (File Transfer)

    5. Click back, then scroll up the menu till you see "USB Debugging". Enable USB Debugging.

    6. Connect your zenfone 5 to you laptop/PC. The phone should appear in the Devices list in 'Control Panel\Hardware and Sound\Devices and Printers. Leave it connected for another 5 or 10 minutes and it should become available in "This PC".

    7. Select "USB controlled by 'Connected device'"

    6) Disconnect the zenfone 5 from your laptop/PC

    7) Disable "USB Debugging" and disable "Developer Mode" on the phone.

    8) Reconnect zenfone 5 to your PC/Laptop. It should now appear under "This PC" every time you connect and you should now be able to view and transfer files between you PC and zenfone 5.

This discussion has been closed.