Charging issue after android 10 update

sharimkhan22sharimkhan22 Level 1
edited September 2020 in ROG Phone 2

Currently I'm having issues on rog 2. The charging stops eventually and i have to remove the cable and plug it in again in order to charge


  • Is it really due to A10 , this is the exact problem i am facing right now and its kinda bothering as of lockdown Asus service centre is closed !!

    So seems more like hardware fault

  • InnoXenTInnoXenT Level 1

    Same happening to me

  • FakhryFakhry Level 1

    Me too...

    The fast charging mode didn't appear


  • Same issue with me also! After the latest update the phone doesn't charge with original charger. Im using Poco x2's charger and it seems to work ok,but its really strange that original charger is so lousy! Please Asus being such a reputed brand and selling such high end products like ROG Phone 2 you guys can't even provide good software support. I don't think I'll even think of buying any future Asus product. Disgusted!

  • Are you experiencing this issue with the side port too (using the same cable) or is it just the bottom port?

  • Same problem...

    Original charger is not working properly.

    Removing cable again and again.

    Also mobile is not fast charging .

    Please help

  • Same problem on ASUS Zenfone 5Z

  • PhlpPhlp Level 1

    Mine is not charging when i plugged on aero cooler, but the bottom port is o.k, and also if i remove the aero cooler and charge it on the side port its working, is my aero cooler port really broken? Thanks in advance.

  • varunkoshti0709varunkoshti0709 Level 1
    edited May 2020

    Same problem. Its kinda irritating when you play a game and you plug it in order to charge the phone and play , and when you are done playing, you realize instead of charging, its DRAINING!!

    On my bottom port, this happens very often. I gotta reconnect like 5 times in 10 minutes.

    But on the side port its less frequent, but the problem is still there whatsoever on both the ports.

    My software is upgraded to A10.

    Using the original cable.

  • My side port will disconnect and reconnect with the cable still plugged in. Like I plug it in the side set the phone down and it will begin charging then disconnect then reconnect. It's not the cable either because it works perfectly with the bottom port. I was reading that the side usb port is 3.1 generation 2. Is this correct? Because that's what the allegedly what my cable is. Anyone else experienced this? It only does this when I try to use this specific cord on the side usb port. My other cables work fine

  • Same issu with me bro main c type charge faster then side one

  • EXACTLY THE SAME for me as well. Other cords will work with the side port without disconnecting and reconnecting but slower. Not a huge difference in amps but it's slower regardless. Im going to buy a official hypercharge box and cable set on Monday and see if this problem takes place

  • When I connect my charger to the bottom port it doesn't charge. I thought it was the cable with the problem but when I connected it to the side port it started charging. I restarted my phone and sometimes it worked but after a week even the reboot can't solve the problem. I think this is probably a cheap hardware issue.

  • OPCOPC Level 4

    The charging issue came to me couple of days ago. Phone was connecting and disconnecting on both ports and on the Aeroactive cooler. Tried an older Samsung charger and cable and it was working fine, but charging slow. So the phone was fine, which is the most important.

    It turned out to be the original Rog 2 cable. It was loosing connection on one side. Pins within the metal jack must have got damaged. If I would plug that side of the cable in the charger, it would loose connection on the charger. The cable otherwise looks as new.

    So I bought a new USB-C 3.2 cable rated 5A (100 W). This will make sure the phone gets enough juice even with heaviest load in gaming. Downside is that such a cable is quite expensive.

  • same issue with zenfone max m1.

This discussion has been closed.