Clock "alarm report" is buged - voice alarm always include the "colon" in the time.

jumapao28jumapao28 Level 1
edited September 2020 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: asus rog phone 2
  2. Firmware Version: android 10
  3. Rooted or not: not
  4. Frequency of Occurrence: always during alarm
  5. APP Name & APP Version (If your issue relates to the app): app:clock & v6.0.0.59_200210

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Alarm report is buged when i set an alarm for example like 4:30am and when it alarm the voice alarm will read the "colon" in the time it say its FOUR"COLON"THIRTY AM. Now im not using the alarm report feature its annoying to hear

. Please fix..


  • It's not a bug. It's how the text to speech engine we use work, but I understand how you might get annoyed after a couple of mornings.

    This is not something we will update unless we switch out the text to speech engine

  • I have now found the solution i just needed to set up the voice settings in the clock settings and it really works now its saying the right time and the right words. I thought it was corrupted after the update but now its ok. :)

  • Good thing you solved it.

    For others who might encounter the same issue. This can be fixed by searching for "text" in settings -> tap text-to-speech output -> tap the gear cog -> toggle the "Number processing" off


This discussion has been closed.