Valve Index VR won't connect to Zenbook Pro Duo UX581GV-XB94T

zacharysideszacharysides Level 1
edited October 2020 in ZenBook
  1. System: Windows 10
  2. Battery or AC: AC
  3. Model: Zenbook Pro Duo UX581GV-XB94T
  4. Frequency of occurrence: Always
  5. Reset OS: No
  6. Screenshot or video: N\A


Detailed description:I cannot get my Valve Index VR headset to connect to this laptop with the Cable Matters USB C to DisplayPort adapter, and the Valve Index will not work with HDMI.

Does the Thunderbolt 3 port connect to the RTX 2060, or the Intel UHD 630 graphics?

I'm curious if anyone has used the Valve Index with the Zenbook Pro Duo



  • Hello zacharysides,

    We had been tested on this issue just a while ago, and it is very likely related to the compatibility of adapters.

    Please kindly change one.

    Thank you.

  • deckarddeckard Level 1

    Having the same issue, how do you 'change one' ?

    The issue is using a tb3 to displayport adapter it is only connecting to the UHD 630, as is the desktop.

    Only when you run a game will it use asus link adapter (which will then be listed as a separate monitor in addition to desktop, with the HMD listed as another, still connected to the UHD 630).

    Opening the TB3 applet doesn't give any options with the tb3 to dp adapter, on its own or with the HMD plugged into it, no way to tell it to use the RTX 2060 by default.

    For reference I'm using the KiWiBird TB3 to displayport adapter, but I don't think it's the adapters compatibility, it's that you can't select the graphics card the port uses.

    I'm wondering if an egpu would suffer the same problems.

  • XaryiXaryi Level 1
    edited May 2020

    I specially selected a Cable Matters adaptator for the same use. It can output 8K no problem and it has been working just fine with an output to a second monitor but when I try to connect it to the valve, steam VR ask me to switch the screen mode from duplicated to extended. The problem is that everytime I do that it instantly come back to duplicated.

    I think the problem is Asus gestion of the second screens. As a professional working a lot with VR I do need my 3500€ machine to work with a Valve and have a functionnal thunderbolt port. Either the support give us a way around this either Asus need to work on a update for their flagship computer. It is innaceptable to not think of some problem as bad as this.

    And please don't tell me to change again my adaptator, it has been the third time I order one and I know this one is working on other pc.

  • deckarddeckard Level 1

    My UX581 exhibits this same behavior of reverting from extended to mirrored, and steam VR giving that error.

    I did buy this laptop with an eye it was VR capable/ready, because its specifications are far greater than my desktop PC it should work much better, otherwise I could of just bought a new desktop for less.

    Plus my desktop PC is in a small room, only really capable of using the Index for seated VR, where the laptop would give me the flexibility to use a larger (temporary) space.

  • XaryiXaryi Level 1

    Same thing, I need it to make presentation in larger spaces, with client. I can't find anywhere how to force another option to avoid this issue. And even if I do it does not guaranty that it will work, it's only the first step.

  • deckarddeckard Level 1
    edited May 2020

    Are there any official possible workarounds @Blake_ASUS ?

    Really would like to at least try VR on this laptop if I could without having to buy something else, probably also stupidly expensive.



  • Hello deckard,

    UX581 works with VR, this is what we have tested.

    However, we are not able to test all kinds of adapters.

    Really sorry about that.

    All your feedback have been reported.

    Thank you.

  • deckarddeckard Level 1

    Hi Blake,

    Thank you for your reply.

    Unfortunately that obviously doesn't tell anyone much, it's a bit like my car manufacturer saying that the audio unit has been tested and it works with phones, but neglecting to say which (ie tested with iPhone but not android or blackberry), and then no one wants to fess up to this fact when people can't get them working.

    Obviously the UX581 has more than enough specifications to run VR with ease, but it would seem only compatible (I'm assuming as I don't have one) with headsets that connect to the HDMI port, but nowhere is this mentioned.

    This is a a flagship product, it would make sense the owner also has a flagship headset to accompany it.

    Perhaps add a disclaimer :does not work with Valve Index: to the product page.

    Could I also assume that the newer dual screen (ROG Zephrus Duo 15 w/tilting screenpad) models would also not work with an adaptor for the exact same reasons (btw I don't think it's the adaptors fault, it's the way the system sees and handles them that I believe is the issue) ?

    I guess, bottom line, will not work with VR via the thunderbolt port, the Valve index requires a native external displayport only.

    Hopefully others searching will now see this and seek an alternative (headset or laptop).


  • XaryiXaryi Level 1

    I am still in search of a solution, maybe it's because i just don't want to believe something so basic as professional VR was neglected by a firm claiming to do everything for creators.

    If, as you claim, the index is working with an adequate adaptator please juste give us the reference. If a multi billion internatial firm is not capable of testing all adaptators you should imagine pretty well we are not able too. It would make our life way easier both for you (no more post about the same subject) and for us (being able to finally work).

    If it's a software problem when can we expect an update on the zenbook drivers ? If it's a hardware problem why is it not advertised as such on the product page. I mean a TB3 port has no reason not to work with an Index. If it's an adaptator problem what is your recommandation because I tested adaptators way above specs and that I saw work on other pc and still nothing.

    Finally, if you have any kind of workaround it will do. I mean after all posts made about this subject and all the feedback send to your engineering team we could reasonably hope for anything to make this work, at least a definitive answer and an explanation.

  • I haven't tried myself yet but I believe the HDMI is wired straight to the RTX. Would an adapter from hdmi to displayport do the trick?

  • deckarddeckard Level 1

    Unfortunately the Index requires a higher bandwidth connection than the HDMI out can't supply, so any HDMI converter to displayport is doomed before you try it, but thanks for the input.

    As more high end laptops use this port to be a catch all (cop-out) to adding dedicated ports to save money, either headsets will have to accommodate, or laptops.

    So while we're at this impasse, obviously we're looking for an alternative workaround which hopefully will be to find a working TB3 to dP adaptor.

  • deckarddeckard Level 1

    An article on upload vr suggests that if you open the nvidia control panel applet and navigate to physx, if the symbol is connected to the integrated UHD 630, then it's not likely it'll work, period.

    Reference : (Can't post links yet)


    oculus rift-s-valve-index-no-hdmi

  • XaryiXaryi Level 1

    This post shows that it's not always true, but we can't get a straight answer from support. Only corporate talk.

    Can't post links either but try searching reddit oculus rift s laptop issues usb c

  • deckarddeckard Level 1

    I had a look at the reddit post in question.

    Best I can tell is he changed something in the bios, downloaded an applet, and used a particular adaptor.

    I looked in the bios, and only saw 1 item that pertained to the thunderbolt port, and I can't see that changing the option would help (see pic).

    As for the applet (TBCC), that's already pre-installed with the laptop, so no chance of installing it after the bios change.

    But one thing that was interesting was his adaptor.

    Unlike the one I have, he had a TB3 to dual DP adaptor. What is significant about this one and not others, is this one is TB3 only, ie it won't work in a usb-c port, it has to be TB3. It then shows up in the TBCC app, and possibly this is why it works.

    My adaptor does show up, but it shows as a USB device, if you check eject USB tray app, there it is.

    Unfortunately his adaptor was from a US website, where it was out of stock, but searching for another in the UK, in fact the rest of the world I still couldn't find one in stock anywhere.

    So it doesn't look like I'll be able to use it for VR anytime soon.

  • TimsonC200TimsonC200 Level 1
    edited June 2020

    Similar issue with the Oculus Rift S, tried already three different adapter:

    none of these are working, so my question is: should it work? is Asus or adapter producer or Oculus the problem/responsible?

  • deckarddeckard Level 1

    This is as they say, the 64 thousand (or million) dollar question.

    Only when someone has a working solution might it be possible to reverse engineer the answer.

    I don't think support has a clue, or are just not interested in trying to answer the question.

    We know the hardware (the HMD's) aren't at fault because they will work on the desktop.

    We know the adapters only may be the problem, because they will work on laptops that only have a single GPU, and are happy to output via a USB-C port (in other words it isn't really using thunderbolt 3).

    So really, the answer is either the laptops, or the way they see and handle the thunderbolt 3 port , and then see peripherals that are plugged into them.

    And for the record, at least one of those adapters pictured have I have heard have been used successfully on a USB-C/TB3 laptop and an index, though I forget exactly where I read it (or it was reddit lol).

  • deckarddeckard Level 1

    Hi @Blake_ASUS,

    I would like to ask ASUS, via yourself, just how many adapters do we, the consumer, need to try before someone comes clean and tells us that this isn't going to work via the TB3/USB-C port ?

    In this thread alone we've used at least 9 adapters, and certainly 6 plus that are unique versions.

    Also 'UX581 works with VR, this is what we have tested', doesn't tell anyone anything, because that could mean it had only been tested by HDMI, which is meaningless to anyone who owns an Index and the Rift S and is required to use the TB3 port as there is no displayport output.

    We can't go and badger Valve/Steam until such time as the manufacturer tells us it's a software problem on their end, because they'll just tell us it works on desktops an other laptops absolutely fine.

    One of my adapters is TB3 only, does show up in the TB3 applet, runs a connected monitor just fine, running games that would need the 2060 GPU to run at more than 2 fps.

    Could you please put this forward to someone technical at ASUS and report what they tell you about this specific issue, not just give a generic response that VR works on the UX581, many thanks.

  • Hello deckard,

    Thank you for your feedback.

    I have reported to related department.

    Thank you.

  • XaryiXaryi Level 1

    What does it means ? It has been several post and month since you told us this. Many people asked and yet no clear answer. If you sell something labelled pro you need to provide adequate support. Right now I am stuck with a PC pretty much useless because I work with VR and this top tier 4500€ priced PC won't work with the top tier VR headset that came before. Despite being labelled as VR ready and having in theory all the hardware to do so.

  • I just forward a message which I got from CableMatters support and after a lot of research I agree:

    "To connect a computer to the Oculus Rift S, the video port needs to be wired to the discrete graphics card. On most computers, USB C / Thunderbolt 3 ports are wired to the integrated graphics card, making them incompatible with the Oculus Rift S. The only way to connect to a VR headset using your ASUS UX581 i9 9980hk will be through the HDMI port.

    Unfortunately, we don’t offer or know of any HDMI to DisplayPort adapters that are compatible with the Oculus Rift S. So there is currently no way to use your ASUS with your VR headset.

    To use your laptop with a VR headset, you would need to get a headset that has an HDMI connection instead of DisplayPort (ie the original Oculus Rift, HTC Vive, etc…)."

    Some laptops are able to switch the direct port, but it seems that the Zenbook can not or atleast asus has no switch implemented for it and yes one of my reasons to pay so much for a laptop was VR....

This discussion has been closed.