USB OTG Not working on Android 10 Beta Zenfone 5 ZE620KL

aerialusaerialus Level 2
edited September 2020 in ZenFone 5 Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone 5 Ze620KL
  2. Firmware Version: 17.0615.2003.22
  3. Rooted or not: NOT
  4. Frequency of Occurrence: Always

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.



I just realized that USB OTG does not work on the Android 10 beta Firmware (Asus Zenfone 5 ZE620KL),

i already tested with Flashdisk and Mouse/Keyboard and all of them is not worked (no respond at all)

Please investigate this issue.


  • Hi aerialus

    Thank you for your asking. Kindly provide the information below so that we could better assist you.

    1. Could this OTG cable works on other phone? Besides, could this OTG worked in the previous version? Which version?

    2. If the OTG cable can work on other phone, could this OTG cable work in "Safe Mode"?

    # How to enter and exit "Safe Mode"

    3. If the situation remain the same, is there any error message?

  • aerialusaerialus Level 2

    hi, thx for the response,

    after i tried to restart my device, the OTG function now is work.

    i dont know what is the cause of yesterday's case.

    For now it works fine 😅

  • Great! I'm glad that your issue was solved. 😉

  • LitoLito Level 1
    edited July 2020

    Mine is not working too after the upgrade to Android 10

    Build QKQ1.190723.002.WW_Phone-17.0615.2005.25-20200604

  • Hi Lito

    Thank you for your asking. Kindly try some stay-at-home troubleshooting tips below:

    1. Change another cable. Does the cable you use now work with other device?

    2. Re-boot your phone

    3. Try "the Factory Reset" 

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

    If the situation remains the same after performing the factory reset, kindly provide me the information below

    1. Could this OTG worked in the previous version? Which version?

    2. Could this OTG cable works on other phone?

    3. Is there any error message?

This discussion has been closed.