Zenfone 5z - No service

pretender777pretender777 Level 1
edited September 2020 in ZenFone 5 Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone 5z ASUS_Z01RD

Firmware Version: I cannot find it, not appearing in settings>about phone>hardware information

Software info: WW_100.01.44.98_20191115

  1. Rooted or not: not
  2. Frequency of Occurrence:
  3. APP Name & APP Version (If your issue relates to the app): n/a

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Had his issue before, then updating from android 9 to 10 somehow helpe fixing the issue

tried rebooting multiple times, factory reset. same issue

using test mode #*#4636#*#, it shows that the mobile radio power is off


  • Please update to latest version and then check radio frequency has been optimised in latest firmware i.e.

  • How do you download and update if your phone has no service?

  • My Android is: ASUS ZenFone 5Z (ZS620KL-S845-6G64G)

    I've tried everything to get service. I did upgrade when it it told me I had one. It upgraded to OS 9 and when upgrade was complete I lost service.

  • Hi [email protected]

    Thank you for your asking. Kindly provide the information below so that we could better assist you.

    1. Your current firmware version

    Setting >System>About Phone>Software information

    2. What do you mean "lost service"? Does the device lost both SIM signal and WiFi signal?

    3. Please enter "Safe Mode", does the issue remain the same? If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    4. Check on SMMI test

    Calculator> type ".12345+=">SMMI TEST>Single Test>Wi-Fi Test/SIM Signal Test

    Furthermore, please try the steps below as manual upgrade guide.

    1. Downlaod firmware file on a PC, put the file into root storage via micro sd card or cable

    2. Reboot your phone and check for the firmware update notification pop-up

    3. Tap "System Update File Detected..." and follow the steps shown to update the firmware.

    Please note that once the update is completed, all data, apps, settings and personal information will be deleted. Kindly backup your data first. Also, please reply me your current firmware version first so that I could suggest you the right firmware file to download.

    #Firmware Update Guide

  • I have the same problem but it happened right after ASUS gave me an update on June 6th. The internet and WIFI and phone service were working absolutely fine before that. My phone is only 9 months old. It says the I was updated to OS 9. I've tried everything to get it to work. I want my service back!

  • Software Information: WW_ZS620KL_90.11.162.111_20191008

    Do you need anything else? I tried everything that has been suggested.

  • edited June 2020

    Hi [email protected]

    Since you already lost the signal, please backup your data via USB cable and do the factory reset: Settings>System>Reset options>Erase all data(factory reset)

    If the situation remains the same, please download WW- (Android Q) in PC>put the file in micro sd card>insert the card in phone>move the file to root storage of the phone>reboot your phone and check for the firmware update notification pop-up>tap "System Update File Detected..." and follow the steps shown to update the firmware.

    #ZS620KL Firmware Spot


    #[Zenfone] How to update firmware on my phone? (manual update)


    If you have any further queries, please do not hesitate to contact me.

  • AlwynAlwyn Level 2

    Done boys, I didn't capture good picture it was still blur. I assume it's an hardware issue and it's cause us to pay for it. Glad this phone servived 2 years with me. Changing my phone but, not going for Asus anymore!!

This discussion has been closed.