5GHz Wi-fi download speed dropped significantly after flashing build WW_17.1810.2003.145

chrislingchrisling Level 1
edited October 2020 in ZenFone 6

Hi all,

I have flashed with the latest build WW_17.1810.2003.145 yesterday and found out the terminal download speed using 5GHz WiFi has gone down from 500Mbps to ~100Mbps.

I had my other iPhone 11 Pro as a control test which gives a steady 500Mbps download speed.

This fix was supposed to optimize the WiFi ironically.

Has anyone got similar experience?

Kind regards,




  • dt808dt808 Level 2

    i noticed the same thing after the update. my download speed has been cut in half over 5ghz wifi. upload speed remains unchanged.

  • Also, when moving away from my WiFi router the phone is not able to switch to the 2.4GHz channel but still camping onto the 5GHz, since the signal is too weak so it shows "Obtaining IP address" without an active connection.

    I have to power cycle so that it knows to camp on to the 2.4GHz channel.

    I'm using Netgear RAX20 WiFi router with smart WiFi turned on

  • paras0710paras0710 Level 2
    edited April 2020

    Please fix switching from 5 to 2.4 GHz and vice versa. Zenfone 6 is not able to switch swiftly it disconnect with '?' Sign on wifi icon i have to switch it off and on again. i never had this problem with my previous phones also other devices including phones in my home is also working properly. The router i am using is mi router pro AC 2600 ut is powerful router with very good range still zenfone 6 having issues. Problem was there in previous firmware too. Did not check speed issue.

  • rubennatanaelrubennatanael Level 1
    edited May 2020

    My Phone is ASUS ROG 2. Having the same problem here. 2.4Ghz connection is working well. 5Ghz download speed only clocked in 2Mbps but normal upload speed. Other devices running well in the 5Ghz wifi connection. Please advise with solution.

  • Please let us know which Router you have and make sure you're on the latest router FW

  • Router Tenda AC1200. My other phones running 5Ghz with full speed. Asus ROG laptop running 5Ghz wifi well with max speed. The Asus Rog 2 FW 17.0230.2002.32. its the latest update i can get.

  • vtrobvtrob Level 1

    My Asus x00QD is downloading at half the upload speed. Down 25 Mbps. Other devices , Asus laptop and lenovo tablet Samsung note phone download around 100 Mbps

    Using Huawei q2 pro router.

    On a Huawei H112-372 I have similar issues. Other devices download at about 200 Mbps but phone is only at 70 Mbps

    Any chance it doesn't like a particular channel? Should I separate the network into 2.4 and 5 GHz instead of letting the router decide?

  • dt808dt808 Level 2

    i'm on a asus RT-ACRH13 router with latest firmware. my download speeds now are half what they were before the update. i'm not sure if the phone update caused it but its definitely slower now. other devices on the same router and frequency are ok. thanks.

  • Thanks! I will feedback your routers to our devs when more of you have replied to see if there's any connection.

    I can say that personally, I have only had bad experience with letting the router device if it should be 2.4 or 5ghz because it will almost always pick the one with the strongest signal and not the fastest speed.

  • Working great for me with latest fw

  • facing issues with my download. if i need to change the router please let me know. no email has been sent by the network guys too.

  • I've tried to replicate this issue but I receive full speed at 5ghz with several routers. Are you still experiencing issue? Sometimes doing an extra restart after an update, can fix the weirdest issues. You may also try to reset your mobile wifi and BT settings in system settings -> system -> reset options

  • dt808dt808 Level 2

    i seem to be ok now. not sure what happened but i think i'm getting full speed on 5ghz now.


  • _jis__jis_ Level 5

    Did you restarted your phone in the meantime?

  • dt808dt808 Level 2

    yes i restarted my phone several times since i last had the problem but not because of the slow wifi. i also restarted my phone several times when i first noticed the slowdown but it didn't help at that time so i'm not really sure what fixed it.

  • Yes I am. The problem still persist. I did all the reset wifi settings and restarted my phone. Checked all the router setting and other devices. Its only exist on the Asus Rog Phone 2.

  • Try to disable randomize mac. This is what we changed in the latest FW. You can change this by going to your network settings and click on the cogwheel next to your 5ghz connection. Under Privacy, change from randomize Mac (default) to Use device MAC.

    If you have dev options active, please turn it off.

    If this doesn't help, then please check your 5ghz speed with other routers.

  • @Anders_ASUS i have the same issue as rubennatanael, my wifi keep connecting and disconnecting to the 5ghz wifi.

    if i remember correctly when on android pie , i can connect to 5ghz but it says no internet connection.

    others phone works fine with this 5ghz band..

    i only have this problem with rog phone 2. maybe because software bug?

This discussion has been closed.