ROG Phone 2 no longer charges at all

ConsolarificusConsolarificus Level 1
edited September 2020 in ROG Phone 2

Last night my ROG Phone 2 (latest update) was acting strangely and having ghost touches, such as clicking on random links while scrolling websites. This morning, since the battery was low, I plugged in the charger and the charging light did not turn on. I tried a different charger, same thing. Tried a different outlet, still no luck.

So now the battery is at 0 and the phone will not recharge.

Is a warranty repair my only option at this point? I can't even do a factory reset since the battery's dead. I tried the side port too, no luck there either.



  • EdiEdi Level 1

    Hi, I also have a charging issue with my ROG Phone 2, 12Gb, 512Gb. Yesterday the issues started and have persisted, furthermore the left bottom side of the phone gets very hot especially with the original charger and cable. It wont charge at all with the original charger and cable. The phone is showing Hypercharge, but the battery percentage staying between 48-50% and the percentage was 49% it got plugged in. when I plugged in a QC 3.0 compatible batterypack it charges with the ++ sign on the battery status indicator on the phone and it also charges with a regular USB to type C cable. What could this be? Software issues or hardware issues?

    It was a headache switch from iOS to Android running on ASUS ROG Phone 2, and now it starts again ?

    I will bring the phone in to the supplier where I purchased it, but I would like to be able to give them as much information as possible, so I can get a replacement phone straight away as I do all my work on my phone and really need it. I'm starting up my new company and just when I need the phone the most there seems to be issues with it.

    I would appreciate it very much if an ASUS representative could answer this and shed some light on the issues with my phone.

    I'm located in Sweden and the supplier is NetOnNet.

    Thank you in advance, Edi

  • If you have also tried a different charger, then yes unfortunately a warranty repair is your only option. Apologies for the inconvenience.

  • Have you tried to charge it with another charger or cable?

    When you say it gets really hot, is that only when charging AND using the phone, or simply charging? Charging and using the phone at the same time can result in very low or no charging, as the phone is detecting the high heat and limiting charging to save itself.

    If it only gets hot and/or fails to charge with the original cable, then I recommend contacting your regional ASUS support to get a replacement. The unit itself may be fine.

  • AhsenAhsen Level 1

    I have the same problem .

    DO you have a solution ?

  • Hi,

    As of today my primary charging port is not working. But the side port is working. The most surprising thing is that it has not been 6 months after my purchase of the ROG II.

    It makes me real dad that neither the phone is performing to optimum level in respect to the game and now the charging issue. Due to COVID the whole nation is under lockdown and it any more issues arrise then what are we supposed to do.

    The phone already had heating issues. Games not functioning properly. Specially Call of Duty. The blackout issue is still not gone after the last update.

    Really disappointed. 😟

  • Hi @LP_ASUS ,

    I would like to draw your attention to same problem. I m facing same issue and I have never used another charger or cable. I have tried both slots and charging without using the phone is too too slow, like hell. I am attaching a screenshot for your reference.

    Above pic is charging from downside port. It is showing around 7 hrs for phone to be fully charged.

    This second pic is for charging from side port, black one, not orange one. Here it also shows same around 7 hrs to be fully charged. In both case I m not finding ++ sign while charging which shows fast charge I Guess. I am having latest update on my Phone.

    Is this software or hardware issue?

    Requesting you to help on the same ASAP.

    edited April 2020
    1. How often does this happen? (Rarely, Occasionally, Sometimes, Often, Always)?
    2. The USB type C plug on the cable has two sides. Have you checked if both sides show the same issue?
    3. Do you have a 18W or 30W adapter?

    This could also be temperature related. When the phone sees that it is near 50C, it will slow down charging to protect the hardware. This could be due to the ambient temperature or perhaps an app is working in the background. Please measure the temperature multiple times during charging, and also record the ambient temperature at that time. If you think it is due to an app, then kill all apps temporarily by going to system settings -> Battery -> PowerMaster -> Auto-start Manager -> uncheck all downloaded apps. After this go to system settings -> Advanced -> Mobile Manager -> Memory Cleaner -> Set up Super clean mode -> enable -> go to recent apps overview -> Clear all.

    If you have battery care active, please turn it off. If it is already off, go to PowerMaster App Info and clear storage to reset the app.

    Try testing with another cable and charger if you can. Please report your results when you have tried all of these steps.

  • You should also try different switches , sometimes the port is not able to provide as much energy as required , just a suggestion might help you .

  • HarveenHarveen Level 1

    I have the exact similar problem the Bottom Charging port stopped functioning , I get a error message that the temperature at the Bottom charging port is too high . Side Charging port works , however the warning message still appears intermittently and I am not using my phone meanwhile to be safe . More details can be checked by clicking on my profile name.

    charging port issues is apparently a known issue with Rog phone 2 , however Asus is adamant in accepting it !



This discussion has been closed.