Firmware Update not possible

edited October 2020 in ZenFone Max Series
Model: ZC520TL
Firmware/App Version: MRA58K.WW_Phone-
Frequency of Occurrence:
Rooted: No
App Name:
Description: The phone does not Update.

I bought this phone used, the person who sold me said that the phone was 'Corean', but they flashed a Global ROM.

The Phone arrived Wiped, the Phone miss the GApps so is without Account, I tried to install the GApps, the Play Store and Play Services and nothing, they don't work.

I tried to update the phone automatically but nothing, I tried to install the update but with every official ROM that I try there are some error, I tried the WW version and say that the version is for NDR90N and my phone is MRA58K.

I tried other versione, US, ID, TW, JP, but they have some error, they say that the phone is WW and not US, TW, ID or JP.

I don't know what to do.


  • Hi ragmio320,

    Good day.
    I've texted you by PM, please kindly check on your message box.

    Thank you.
  • Hi @ServiceE_Asus ,

    I am having the same issue, and my phone exactly the same with ragmio320, could me please assist?

    1. Bootloader can't unlock, even using UnlockTool from Official ASUS
    2. My phone won't update
    3. My firmware is WRA58K.WW_Phone-, I want to update to WW-14.10.1707.46, it failed and says this firmware is accept for NRD90M, and my phone is WRA58K
  • Hi ericlee1801

    For ZC520TL, there will no longer have any maintenance. Sorry for any inconvenience this may cause. Thank you for your understanding and support.

This discussion has been closed.