Asus 6z battery charging issue.

bishusha345bishusha345 Level 1
edited October 2020 in ZenFone 6

Since i updated my phone with latest fota update there is big issue in my phone. Whenever i put my phone on charging it only show 'charging' not "fast charging" and so the speed of charging is very slow. It takes about 7 hours for full charge. Its been very annoying since this bug have been started.

Its not only my problem but of many user complaining about this.

Please fix this issue ASAP.???



  • We've seen complaints but have received very few logs and none of them that can confirm that there's a software issue. Have you tried charging with a different cable? If the cable breaks, partly, then fast charging will stop working. This is a VERY COMMON issue which needs to be solved with your local ASUS Support.

    If you have tried with the bundled asus charger and multiple cables without getting fast charge, then I would very much be interested in logging your phone to find out why.

  • Cable is absolutely fine. And have tried many charger and nothing happened.

    But sometimes its also show fast charging not everytime.

  • And you don't have battery care enabled? Even with slow charge, it shouldn't take 7 hours.

    You can find this setting in system settings -> battery -> PowerMaster -> battery care

    Make sure it says "off"

  • Olá, tenho o mesmo problema amigo! Depois da atualização 110 aconteceu isso, quase todas as minhas cargas levam mais de 7 horas para 100% . Antes no Android 9 não acontecia isso, é lamentável não ter nenhuma atualização até agora para corrigir isso. Outro ponto é que depois da atualização o Instagram só aceita vídeos de 15seg

  • I have same problem . After last update phone is charging slow

  • No reply? Battery care was enabled right ;)

  • Hello, I have Asus 6z

    I am also facing charging issue, it took 7 hours to charge my phone, i tried with many other fast charger but its not working.

  • Could you try out the methods Anders already suggested here?

  • futcher76futcher76 Level 1
    edited March 2020

    As of last night, my phone also started to do this. Sometimes it will fast charge, sometimes not (using a third party charger). When not fast charging it says it will take 8hrs to reach 100%, in fast charge it is significantly lower. Everytime I plug in the Asus provided 30w charger it always states that is hypercharging however battery is not charging at all. In fact it drops % charge. This happens with both main and aux port, with or without fan attached. Battery Care has not been enabled at any stage. Am happy to log the phone if required

    Edit: Just realised this is a ZF6 page, will move it to an ROG2 page. Apologies

  • My ASUS 6Z taking the taking 7 hours to full charge.

    1.Same charger is used to charge the OnePlus phone , charger is working perfectly so charger has not problem.

    2.Battery care in Power optimisation is off only.

    3.I did reset my phone and I check again the charge the phone ,same issue still showing.

    Could you please help on this?

    Lot of time to keep my phone idle to full my charge , it shows people will shift product .

  • edited July 2020

    Oneplus charger uses dash charge technology which is exclusively for OnePlus phones, it's fast charge will not work for other phone.

  • edited July 2020

    I ask question , is not able resolve with your previous answers .so I put all possibilities check , so I ask u is any software issue ,after I update the phone . That's one we can not check?

    Asus charger used to charge one plus phone it's working well, I m saying this for "my charger is working fine"

    Please give resolve rather then replying.

    Every thing working fine don't ask me to go service centre , if it's any problem in battery or charger it gradually decreasing the life of battery not sudden?

  • Bro I am an asus mobile user just like can't help you with that.

  • Why reply is not come from Asus leaderboard for this ?

    When they release this product , they talk about battery like , compare to other phone we are not reduce the size battery if we reduce the size of battery life also reduce and we are giving space between cells inside the battery so it's give long life ..

    They intro of the phone false information?

    Please any Asus leaderboard person reply to the issue.

  • Zenfone 7 or 7z is going to be released we are not their priority now since expect this type of behavior from now on and I hate to say this but keep your expectations low regarding any bug fixes and updates as 6z is not their latest model.

  • I am using the phone for a year almost love when it was brand new but now people are not taking initiative to solve the customer care complaints the phone is although good no doubt but still its lacking proper support from leaders of asus

    might they sort out the problem with battery as soon as possible with the update even you use a wattage of 45 charge it will charge the same showing turbo charge at take the same amount of time which is pain in back to just sit for hours waiting for phone to charge . Please take this matter as a concerned and i know Asus will do the needful .

  • After a last update around 15th or 16th July. Even I started facing this same issue.

    The fast charging label is no more. It just plainly says "Charging". Also, there are no plus icons around the battery icon while charging.

    Without resolving this, no one can actually conveniently use their cellphones.

    Will try to go service center on Monday and get it solve there.

  • We coming here for looking solution , but you coming for support ASUS product ,it's very non sense of your comment.

    My phone taking 9 hour to charge full , I bought my phone for 40k , we expect basic thing of product should be correct if it's is not proper , ASUS IS NOT GOOD PRODUCT

    Battery is very basic thing to phone , if it's not proper its irritating one to user . The we have to travel with one power bank to Charge it .

    "Please avoid putting comment if u not having solution to the problem."

This discussion has been closed.