Charging issue

jainhimanshu960jainhimanshu960 Level 1
edited September 2020 in ROG Phone 2

I'm facing issue with my Rog 2, my phone is not charging fast

1. I'm using 18w charger come with the phone to charge

2. I have used Xiaomi 2i power bank with 18w output to charge my phone (still not working)

3. When i restart the phone battery goes down 36% to 29%

4. On charging when i restart the phone it goes 8% to 13% 

5. I'm facing this problem from the 2-3 days

6. Double plus sign on battery icon as well as fast charging text on home screen is also not showing while charging 

7. I have try both usb port for charging still same

8. On charging says 10 hours to charge 100%

What is the issue please help anyone


  • Please help me. Only 1 month of purchase of phone showing this problem

  • sathishinsat2sathishinsat2 Level 2
    edited November 2019

    Hmm. Feel bad. Did you try by changing your ASUS charger cable? Did you use your Asus charger cable in power bank as well? if yes, try with new cable if you have.

    Or, You can try reach out ASUS support/Service center near you. Look out for support option in ASUS page.

  • Did you try factory reset?

  • The two most common reasons why your phone won't fast charge is either because it's too warm or that the cable is damaged.

    I recommend to buy/borrow a high quality cable that you can test with before you contact ASUS Support.

    Point 3 and 4 is new to me. Does this happen every time you restart?

  • Same issue with me also . I bought phone 15 days back and my phone takes 8 hours to charge ? with out using it. I am using the charger they comes with the box

  • Change cable even i had same prob before then after switching to my one plus cable it got solved.

    IDK ABOUT THE BATTERY RISE AND FALL PROBLEM BUT IF U WANNA GET ++ sign while charging try the above method

  • CenimmCenimm Level 1
    edited January 2020

    18w? I got 30w I think your charger is to weak.

    I have this problem when I used Samsung's charger when my Asus cable got broken. Then I buyed a new cable have the same problem but then I found a USB c cable that's was made for 30w+ and then it was back to normal.

  • I have also faced the same issue. Below is my case and solution.


    My batery drained and i used my friend's fast charger as i did not have my asus rog phone 2 charger nearby. Nextday i forgot to take my charger to office and the battery went to 3 % and used another friend's charger and it did charge slowly with the slow charge symbol.

    after coming home i tried with my Asus rog 2 charger and it did charge slow as well. I tried using power bank with quick charge that too charged in slow charge mode.

    I tried changing the cable for the Asus provided 18W charger as well. it did not charge fast.


    I tried using the side charging port with powerbank then after 3 seconds it detected the fast charge from powerbank after that the amin charging port also started detecting the quick charge but it was detecting after 2 or 3 seconds.

    After this i used asus provide charger and cable it did charge slowly, i tried changing cable after that it started detecting fast charge after 3 seconds.

    Please try and let me know.

  • @asus

    Some how i believe it is a software issue as the issue is getting resolved after changing the ports. (the software/firmware that prevents the damage of battery due to over charging).

  • Yeah..i am too facing this problem...i am not getting fast charging get ++ sign i have ro restart the phone sometime this works sometimes doesnt

  • What to do about this issue ... it's getting worse one after another problem ... I like the phone but the increase rate of problem causing trouble .

    Bad thing for asus

  • I had the same problem and i was soo pissed about this. But i got the solution. Its the Adapter😒 i replace the adapter with other 18w adapter and boom it works.. Try

This discussion has been closed.