Charging port temperature abnormalities

OPCOPC Level 4
edited October 2020 in ROG Phone 2

As the title suggest I got the notification saying that my USB port temperature is too high, that I should unplug the charger and take phone to Asus service center. The thing is it happened while I was playing Asphalt 9, with no charger plugged in. Instead the Aeroactive Cooler was attached.

I cannot dismiss this notification and I have the red led light blinking all the time. What shall I do? The video is attached



  • Does the warning go away when the cooler is removed? Will it return if you re-attach the cooler? Is it noticeably warm to the touch where the cooler attaches to the side USB port?

    I've never heard of this issue appearing when the phone isn't connected to power and charging.

  • Does the warning remain after restarting the phone?

  • OPCOPC Level 4

    Solved by restarting the phone. Strange it came out in the first place. Maybe some miscommunication with the cooler?

  • Could be, it shares a data connection. If this error pops up again we may want to log the phone to see what's going on. Like I said, I've only ever heard of this popping up while the phone was being charged. You might have a world's first!

  • OPCOPC Level 4

    LP_ASUS If try to recall the situation, it might be that the cooler was not pressed into the port completely. If I remember, I was playing Asphalt and didn't want to stop while red led was flashing. I remember that sometime during the game I realized the cooler was attached loosely and I squeezed it on both sides to lock it in place. Maybe this triggered the messsge. Otherwise I have the phone for over a month now, played Asphalt over 48 hours and almost all of it with the cooler attached and charging the phone through the cooler. Never a glitch until this strange message. But now everything is fine for the last 2 days. It charges normally playing or not.

  • Hi, I am from India and I am using Rog phone 2. Just now I also get this notification while I was scrolling through my insta feeds. Phone restarts automatically and this warning of usb pops up. I wasn't even charging my phone. Then I google it and saw this post. Please suggest.

  • OPCOPC Level 4

    I have restarted the phone and the message was gone.

  • If the message doesn't go away with a restart, then you need to visit an ASUS Service Center

  • OPCOPC Level 4

    No problems since than!

  • I received this notification this morning and it appeared when my phone was idle and there were no charging cable was plugged.

  • Hi I am from Philippines, I just experienced the same situation with my rog phone2, I am just browsing facebook then automatically restart and notification of usb port high temperature appeared while i am not charging. Why it is happening?

  • ronald1985ronald1985 Level 5

    Quite possibly the phone is too hot?

    Take your phone to a service centre and have it checked out.

  • I am from india my phone is asus zenfone 5z i have experienced a pop notification of battery temperature too high on device while playing pubg whenever i connect the charger rhe notification pops up

  • Adding up more to the thread, I too get this notification, twice for now. It happens while I'm not even touching the phone, it just sits there and cool to the touch. Got this notification a few minutes after an auto-restart. And as it was suggested, restarting the phone again seems to make the message to go away. Weird...

  • Got mine sent for repair. Here's what I got.

    Phone Issue: Charging bottom port is burnt and the other end of the charger cable. (I don't even know why or how this happened because I don't leave my phone overcharge or even get wet, says it was user error as I expected. I love my phone and take good care of it).

    It's been more than a month now and still haven't got my phone. Sad

  • i messaged the asus support center, they told me to send for them to check up, and i know if i send them it will take forever, so i have not send it to them. i don't know what the hell is this stupid issue, Asus rog phone is big company and then stupid issues like this is soo bad for this company. Idk if the problem is the charger or the phone. if its the charger then we can probably buy new charger but if its the phone then idk what to do. also charging doesn't work, i got this yesterday and it hasn't been to normal and it probably never will. i have only 10% in battery, it will go switch off anytime. I hate this, i have reset everything, also back up my phone, it shows in my google drive but it doesn't show restore, so i probably lost everything. I hate this 😫😣😖

  • ronald1985ronald1985 Level 5

    To restore your backup from factory reset, the phone will need an internet connection. It will then ask you if you want to restore from the backup (for example, it will install the apps that you have installed). The problem with the restore here is it doesn't restore the data for you from the apps you have installed. 🤔

  • it shows last backup i did was in yesterday, september 11, but when i restore after factory reset, nothing happens, it doesn't download the apps, so it means i probably have to download everything, probably lost all my pictures too. this is soo sad for big company like this have issue with stupid charger being burnt or something. it says to go to service center, like wtf. service center near me is Philadelphia, Pennsylvanian, who want to travel this far just for them to checkup up this. I give of this shit, i will just have to use iphone 6 now, its has not even been 5-6 months and already this problem. idk how this is fking great phone. Probably go back to Iphone 11 or buy new phone 12. Asus you are worst.

  • ronald1985ronald1985 Level 5

    It takes a while because Play Store will try to update itself to the latest. I have managed to do it on the same day. Sounds like you're not getting that.

    The only thing I can suggest about your pictures if you did lose them from the backup, check Google Photos have them, but this assumes you had it on.

  • so how did you do the back up? maybe i did different, so when i got the USB Temperature Warning, i went to setting and i saw back up to google drive, and then i did, it took like 2-4 minutes. and then when i check google drive it shows, ASUS_1001DC backup, app data 72 apps, i checked the all apps and it was what i had in my phone before doing the backup. but when i do the factory reset, i login with email which i back up from, but it doesn't do the back up. not even 1 apps. maybe this is not the worry, before doing the backup i took screen shot of all the apps. so maybe i can re download it but idk what happened with the charger, its not charging. and idk what the hell is USB Temperature warning. i try to charge using the computer but Asus rog charger that i use doesn't connect to computer but its not USB, so i will buy new charger from amazon and try charging if it still doesn't work then RIP. will move to Iphone

This discussion has been closed.