Smart Lock broken after Android 10 update

john.kissanejohn.kissane Level 2
edited September 2020 in ZenFone 6

Hello, looks like Smart Lock has some problems since the update to Android 10. My phone no longer stays unlocked when I'm at home or work & appears that the onbody detection isn't working either.

Can anyone confirm if this just my phone or a general bug?



  • GFXGFX Level 2

    Working perfectly on my device with Android 10.

    One thing to check is the new location permissions, make sure that Google Play Services are allowed to access location at all times and not only when in use.

  • I don't see anyway to deny/allow it access to the location as Google Play Services doesn't show in the location permissions. Worked ok prior to the Android 10 update, same thing was reported by a Z6 user on a local forum as well when I asked:

    Yea now that you say it, all my smart lock places are not working and the Bluetooth auto load are out too (car starts up, maps loads on connection)

  • I would recommend removing and re-adding your desired locations. When I changed Android phones, it remembered some devices/locations and forgot others, and has had no issues after I manually re-entered Smart Lock info.

  • GFXGFX Level 2

    It shows up when you select "show system" in the overflow menu.

  • One of the first things I tried. There's no way to disable location services for Play Services as far as I can see so probably not that.

  • I'm sorry, I didn't explain what I meant clearly. In Settings>Security and lock screen>Smart Lock> I manually deleted/edited the locations I had saved, and it worked well for me after that.

  • Yes that's exactly what I did, sorry if that wasn't clear. Forgetting about the places, the onbody detection equally seems to have stopped working. It's not the end of the world obviously just something that was working fine before the update to 10.

    edited November 2019

    OK understood. I'll log this one for the software team to chew on as well.

  • @john.kissane

    The software team is requesting a log of your phone for more info. I'll send you a PM.

  • Log sent, hope it helps.

  • Having this problem too. Hope there's a resolution.

  • I was just notified that this is a general Android 10 issue, we are able to recreate this on other Android 10 phones like the Pixel.

    We have notified Google, it will be up to them to resolve it.

  • It is interesting that Smart Lock works for me in A10 at least as reliably as in A9 (rarely does not work).

  • It works fairly well for me too. It does, though, maybe once a day lock when it shouldn't. I wish (tangent here) that google would allow smartlock to work based on wifi connection instead of location. I think gps looses location sometimes and it locks. That may be wrong, but wifi option would be good. Nothing to do with asus, though.

  • For example, I also use Smart Lock to connect with Chromebooks many times per day, so I don't have to fill in my password when I sign in when my phone is unlocked and it works perfectly there.

  • john.kissanejohn.kissane Level 2
    edited January 2020

    Still not working the same as Android 9 for me, my Garmin watch is always connected via bluetooth to the phone so in theory it should never lock but it does. Work & Home should also mean the phone stays unlocked but it doesn't and so on.

    Not the end of the world to have to do the fingerprint/screen pattern unlock obviously but it was nice that I didn't have to with Android 9.

  • _jis__jis_ Level 5
    edited January 2020

    Thanks for the detailed description. I use Smart Lock just like you just have Mi Band 4 and it works flawlessly. However, I know from experience with Smart Lock on Chromebooks that it works for someone and not for others. It's just Google thing, Google problem. In my opinion, any problems have nothing to do with Asus. Even here we see, someone is ok, another is sometimes broken.

    To be sure try at least this:

  • Hi all, the software team just confirmed that they reported this issue to Google. The Pixel also has the same issue. It will be up to Google to push a fix for this one.

  • Thanks for the update, glad to hear I wasn't just imagining it :)

  • Was there every any update with this as it's still not working very well.

This discussion has been closed.