4g doesn't work anymore

SeungSeung Level 1
edited September 30 in ROG Phone 6

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Since today update i can't get internet via my sim card on my rog 6. Is there a way to downgrade the firmware version?

Best Answer

  • SeungSeung Level 1
    Answer ✓

    I fixed it. Somehow forcing it to search for 3g and switching back to 4g worked.


  • DanishbluntDanishblunt Level 5
    edited August 31


    did you try to reinsert the sim card?

    Also did you try to turn of wifi to see if it works?

    Another test is to try and type .12345+= in calculator and test if your cellinformatrion works properly

  • SeungSeung Level 1

    Yeah i already tried to reinsert the sim or stop the wifi or restart the phone.

    I dont know why it's not connected. I tried to reset APN parameter but still doesn't work.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.