Problems with WIFI

jnavarrojnavarro Level 1
edited September 29 in ZenBook
  1. System: Windows 10 64 bit
  2. Battery or AC: AC
  3. Model: UX425EA
  4. Frequency of occurrence: very frequently
  5. Reset OS:
  6. Screenshot or video:


Detailed description:

I have a lot of problems with WIFI connection. Last week I updated the WIFI Driver and continued having the same issue. I bought an external WIFI (TP-Link) device connected through USB and it happens the same.

The curious thing is that I have a second laptop (work laptop Lenovo T470) that works perfectly well using the standard WIFI driver from the computer.

Can you please assess me on what might be happening and what I need to do to make the WIFI work properly?

Kind regards

Joan Navarro


  • @jnavarro

    Please try the following FAQ for troubleshooting.

    If the situation remains the same, I would recommend you to restore your system.

    Sorry for any inconvenience it may be caused. 

  • OK I am just going to jump in here. I am now on my "SECOND NEW" ASUS TUF computer since July 4th. The first machine was a FX706HE-211.TM17-1. The setup started out smoothly and the wifi just came up and ran. Connected to my router without any trouble.

    Let Windows 10 do it's updates and immediately the wifi FAILED! All the drivers were fresh and current. I fought with that machine for a week and finally I could no longer get the wifi to connect at all. I RETURNED IT!

    A week and a half later I decided to purchase a newer machine as I really kind of came to like the first machine. This machine is the TUF706HM-ES76. Again BRAND NEW OUT OF THE BOX it worked smooth without a hitch. As I was familiar with the system software and utilities I went through and set up all the basic system stuff for look and basics. Wifi worked perfectly!!!!!!!!!!

    There was an initial bios upgrade to version 309 and the machine started to have some wifi connect problems. Then I pulled the ripcord and let Windows 10 do the full software updates. Another bios version was installed, this time to version 312. All the other updates were installed and the machine rebooted. Now the wifi no longer works at all. This machine is 1 DAY OLD!!!!! There is not anything from ASUS even admitting there is a problem with their hardware/software, but it looks like just about all the newer laptops are dead in the water as far as wifi connections.

    I have gone through network resets, NO CHANGE!

    Try to reset the MediaTek MT7921 Wi-Fi 6 hardware, NO CHANGE!

    Remove the drivers and device, reboot, go through more network resets, NO CHANGE!

    Reboot, go into the bios, RESET BIOS TO DEFAULT (F9), save and exit, let system start and "SOMETIMES" the wifi will work. It will only work until the system goes to sleep or shuts down and there is no guarantee that it will work the next time.


    There is obviously a real problem here but ASUS is being mute on it. I am not going to upgrade to windows 11. NOT HAPPENING, and people with Windows 11 are having problems as well.

    I am currently doing a complete reset for Win 10. If it works and the wifi comes back. I will limit the update level until this fiasco gets fully fixed. If it doesn't work it is a good possiblity that ASUS will become one of the hardware vendors that I will never look at again. After all this is a second chance and ASUS is failing by not really addressing the real problem. What bothers me is not that there is a problem, but that ASUS isn't saying anything about the ocean liner slamming into this iceberg.

  • OK, this is a quick follow up. I completely reset Windows 10 to version 20H2. Since this is a BRAND NEW MACHINE (1 day old) it has nothing to speak of on it worth keeping. The first time around on this the wifi worked flawlessly.

    As far as I can tell the only real difference between when I first started this machine and now is that the bios was upgraded twice and now the wifi is totally buggered.

    Here is my hypothesis: Whatever bios version this machine shipped with was the LAST worthwhile version and the newer versions are what is crapping out the wifi. If not why is it that on one site, everyone is expounding that by doing a "RESET TO DEFAULT" on the bios is making the wifi work for some people?

    Is there any way to revert the bios back? If I had a do over I wouldn't install any bios upgrades.

  • @Heavens Eagle

    If you encounter this problem, please try the following steps.

    1. Turn on the power and keep the battery power supply mode active (without plugging in the power adapter).

    2. Press the power button for 30s to hard reset.

    3. Enter the system and connect to the power adapter after it has rebooted.

    4. Install MTK wireless network driver V3.00.01.1244 or above.

    5. Install MTK Bluetooth driver V1.3.15.142 or above.

    6. After the installation is complete, restart the device.

    Please be sure to execute all six steps, updating the wireless network driver first, then updating the Bluetooth driver in order.

    Sorry for any inconvenience it may be caused. 

  • Thanks Falcon

    I have already been all the way down that route. Nothing worked, or if it did, it only lasted till the next reboot or the machine going into sleep mode.

    Just a few minutes ago I visited with an ASUS tech person. Once she realized what I had already been through on the troubleshooting, she pretty much didn't try to beat around the bush. I commented that this is a bios problem isn't it and the latest upgrades were the problem. She didn't even hesitate to admit that I was correct in the assumption that the problem is in the latest bios versions from ASUS. This is why the start, go to bios and do the (F9) Reset Defaults works for some folks.

    New machine, worked perfect out of the box.

    Bios upgrade to 309, wifi goes erratic.

    Win 10 big update with a second Bios upgrade to 312, wifi goes completely away. Windows is now version 21H2

    New machine, do a Recovery and reset PC back to original install version 20H2. WiFi worked perfectly after original install but still doesn't work with reset. Only difference is 2 bios updates and Wifi doesn't work at all with original OS and new bios.

    Basically, until ASUS pulls their collective heads out and fixes the Bios FUBAR we are up the proverbial brown river rapids without propulsion.

  • @Heavens Eagle

    I will report your questions to the relevant department. Since you are a newly purchased laptop, if you have doubts about the product, I would suggest you report it to the dealer to confirm whether it can be returned or exchanged. Sorry for any inconvenience it may be caused. 

  • I contacted ASUS tech support last night and actually got a lady that wasn't one of the usual call center "follow the script" people. Once we visited a little I think she realized that I wasn't one of the usual know nothings that call in. I ran through some of the things I had done and basically how nothing would make the wifi operate. Finally I just asked her point blank if the problems that I was seeing everyone have was actually a problem in the bios upgrades that my system installed. She point blank admitted that was the problem and that they were working on it, but no idea when it would be fixed.

    I would revert the bios back to what It came with if that was a possibility, but apparently cannot be done.

  • I have continued to fiddle with this new machine (a TUF706HM-ES76 notebook). I can get the wi-fi to operate, ONLY, if I do a 20 second shutdown press on the power button, then restart followed by a F2 open bios. Then F9 reset, and F10 save and exit. (Not done yet) Windows opens, go into "Settings>Network & Internet>Wi-Fi" click on show available networks where upon none of the dozen or so local networks show up. Go back to Status and select "Network Reset". Let the machine do it's slow reset. The 5 minute wait at this point is stupid!! Who would be doing this if they already had not shut down all open programs or apps.

    Machine shuts down, let it fully shut down and restart it. Go back into bios, F9 Enter, F10 Enter, let Windows restart. At this point it will rarely fire up the wi-fi and connect to the internet. If not I go to "Settings>Network & Internet>Wi-Fi" and click on "Show Available Networks". Usually it will show the local networks at this point and connect though it has to work at it. Usually it will stay connected until the next time I shut down the machine.

    Reboot, Window 10 starts, No Wi-fi connect. Go into "Settings>Network & Internet>Wi-Fi" click on "Show Available Networks" and again none of the dozen local networks show up.

    I can repeat this to get the wifi to work, but "I SHOULD NOT BE HAVING TOO!!!!!" There is definitely a real problem with the current software/bios on these machines. Until ASUS and their partners FIX THIS SHIT, it is never going to work properly! At the end of this week (7-29-2022) I am going to contact Amazon and return it. If not for this problem I like the machine, but no wi-fi means I cannot use it for what I need. The current bios version is 312. This is a second machine that I have tried to make worthwhile and ASUS has just dumped on it.

  • Alright, tonight I went all out. Was going to hammer the Windows 10 OS and try and knock it down. New machine, and nothing on it I needed to keep. The Wi-Fi is basically not working at all and I am one step from returning this to AMAZON.

    Made a boot Windows 10 install on a USB drive and tried to do a install over the original setup. All I did was FUBAR it all. The machine after this would start but Win10 had problems. I finally figured out where to look up the Bitlocker recovery key code to allow Win10 to fix itself. It set working for quite a while and then it went out to ASUS to reset the entire install to the original ASUS start up. It downloaded that from ASUS.

    When it finally finished the down load and all the initial Win10 setup was out of the way (again for the 3rd time) and Win10 started, guess what happened?

    The Wi-Fi woke up went out and connected as it was supposed to before I even entered my code. It has continued to do so and I have locked the machine down to prevent any more updates. It basically went and did a full ASUS brand Win10 reset back to 20H2 version. There is a registry edit that can be done to lock the updates to a set version and prevent an update to Win11 if you so desire. I have now opened worked with and shut down the machine 5 or 6 times and the Wi-Fi has come up AS IT IS SUPPOSED TO, every time.

    The only problem with this is that is stripped EVERYTHING back to the original install. It removed the few items I had place in the machine and everything was exactly as it was originally.

    I did go to the Armoury Crate and had it do a full update on itself. Then shut down and restarted a few times to test the WiFi and make sure it still worked. It still seems to work like a champ.

    Note I did do a Win10 reset back to 20H2 last week and it didn't seem to correct the problem. Apparently one of the file updates for Windows causes a FUBAR problem with the ASUS WiFi device. My machine is now going to stay locked at the current version until ASUS manages to get a valid fix out for their devices, I am talking an actual fix, not a work around.

    If you are more adventurous, you might clean everything off your machine and crash out Win10 so that it will need to have the ASUS brand of the OS downloaded. Be sure to have your Bitlocker recovery key code for the current Identifier on your machine. Do a search and you will find the info to get the code. It can be found at Microsoft in your account there. It is also possible to have your machine make a *.txt with the information, and I would do that as it is much easier than having to try and guess how to find it.

  • Fix Wi-Fi connection problems

    If you’re having Wi-Fi connection problems or see an Wi-Fi icon with an exclamation point , try the solutions below. After each solution, try to open a webpage on your phone to see if the issue is fixed.

    Note: Some of these steps work only on Android 8.1 and up. Learn how to check your Android version.

    Step 1: Check settings & restart

    Make sure Wi-Fi is on. Then turn it off and on again to reconnect. Learn how to connect to Wi-Fi networks. 

    Make sure Airplane mode is off. Then turn it on and off again to reconnect. Learn how to enable and disable airplane mode.

    Press your phone's power button for a few seconds. Then, on your screen, tap Restart .

    Step 2: Find the problem type

    Phone: Try connecting to the Wi-Fi network with another device, like a laptop computer or friend's phone. If other devices can use the network, the problem is most likely with your phone.

    Network: Check whether your phone can connect to another Wi-Fi network, like at a friend's house or a public network. If your phone can connect elsewhere, the problem is most likely with the network.

    Internet: If your phone connects to the Wi-Fi network but you still have no internet, the problem is most likely with your internet connection.

    Step 3: Troubleshoot by problem type


    Delete & re-add network

    Check for problem apps

    Internet & network

    Restart the router & modem

    Sign in to a public network

    Reset all network settings

    Wi-Fi hotspot

    Check that hotspot is on

    Contact your mobile carrier


    Rachel Gomez

  • JarekMJarekM Level 1

    Something is really wrong with WiFi in UX425.

    Similar discussion was several months ago but nobody form asus responded with solution. Look for "UX425EA weak WiFi" thread on this forum.

    In my opinion, hope I'm wrong, it's hardware problem. Probably Asus put wrong antennas in wrong place in UX425 nad signal is strongly attenuated. Reinstalling software (drivers, system, etc) most probably will not help. I've also bought small Wifi dongle form TP-Link (Archer T2U nano), but it has so tiny antennas that it doesn't help a lot. Surprisingly this tiny dongle has better signal (stronger TX/RX) than built in antennas.

    (My Vivobook and Dell work fine in the same environment.)

    I still hope that I'm wrong and Asus will find solution to WiFi problems. But I will think twice before buying Zenbook again.

  • Maybe you need a driver update?

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.