[Issue] Auto brightness in the dark

asusrg87asusrg87 Level 1
edited November 3 in ZenFone 9

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone 9
  2. Firmware Version: WW-32.2030.2030.26
  3. Rooted or not: not rooted
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Hi,

The brightness is way too high in the dark with auto brightness on.

I think the sensor isn't working as it should.

Comments

  • Maybe you can try and use nightlight? The problem with brightness level in the dark its highly subjective from person to person.

  • In the dark the brightness is like this.

    That's definitly wrong, should be at the minimum.

  • sipahi061sipahi061 Level 2
    edited September 12

    @asusrg87 I agree, when I'm in a pitch black room in complete darkness the screen brightness only drops down to %42 and doesn't fall lower.

  • Hello everyone!

    I am sending the issue to R&D as I was able to recreate this.

  • I got a reply from R&D and I would appreciate if you could follow these steps and tell me if this solves the issue.

    1. Launch the calculator application and enter .12345+= to activate the SMMI test. Select Single Test > Light Sensor Test. To check if the Light sensor is normal。

    2. Into Settings > Apps&notifications >See all apps>Click the menu in the upper right corner >Show system, And click the search icon in the upper right corner >search "Device Health Services" >Tap and enter App info page>Storage&cache>Mange space>Click "Reset adaptive brightness">OK.

    This should clear out the cache memory of the Adaptive Brightness, if this is still an issue after doing this please tag me so I can go forward with the investigation.

  • HI Mattias,

    I have done a reboot as well at the end of the steps, it does not solve the issue. The auto brightness is still at the same level as in post number 3 in a fully blacked out room. In my opinion it should be zero

  • My phone also behaves exactly like this.

  • Same issue for me as well and it seems to stuck at 25% with complete darkness in the room

  • Hello!

    Just got a reply from R&D and I wonder if anyone with the same issue could send a log :)

    After you are done, tag me and let me know so I can send you a PM for the file :D

    Please follow the below steps to enable the built-in log tool (Bug reporter).

    1.  Open “Calculator APP”

    2.  Enter “.19595+=”

    3.  Select the Log type according to the type of issue you want to capture. “General cases” will work for most issues.

    4.  After your selection the log tool will exit so you can duplicate the issue or wait for it to happen. Try to use the screen recorder to show your issue when possible. If you can't screen record your issue, then please take a screenshot right after the issue has occurred (as a timestamp) so we know where to look in the log.

    5.  Navigate back to the log tool via calculator and Tap "FINISH AND SHARE".

    6. It takes several minutes for the log to generate. You can exit and do other stuff in the meantime. A silent notification will tell you once the process is done. Tap the notification and then the share button to upload the file to Google Drive and share the link with a moderator. Just make sure to change the permission first so that everyone with the link has permission to view it.

    Note: When you're no longer planning on logging your device, enter “.09595+=” in the calculator and the log tool will stop as well as deleting all stored log files. Make sure to share via calculator. The files found in internal storage -> asus_log are not the correct files (they are only 1.2kb)

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.