USB Connection to PC, OTG, Type- C Headphones not recognizing

AitteyAittey Level 1
edited August 3 in ROG Phone 3

My phone is not recognizing to any PC via usb it's only charging. I tried cleaning my Type-C ports with contact cleaner still haven't fixed the problem. Most likely a software problem. I tried to connect my Type-C OTG Pen drive, when I connect my Pen Drive to my phone it shows a notification showing 'Charging via USB', when I connect my Type-C headphones it shows the same notification. How can I fix this problem without formatting my phone?


  • Mat dengMat deng Level 1

    Same problem here sir. I'm also facing this bugs. After update A12. Still don't have ways to fix this bugs. End up I'm using Bluetooth earphone for gaming. But that delay is so heavy. Also this phone doesn't support aptx or ldac on bluetooth earphone option. Just SBC and AAC only. Fyi, I'm already formatting my phone, already downgrade to A11. But its still the same. No ways to fix. Hmmm....

  • Mat dengMat deng Level 1

    Hello sir @Mattias_ASUS his also facing problem like me. Like u said, if someone have same problem like me. Just show ur thread, or tag u sir. I hope this bugs will fix ASAP

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.