Air Trigger become unresponsive

jasdeepgroverjasdeepgrover Level 1
edited September 2 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG 5
  2. Firmware Version: 31.0810.1226.91
  3. Rooted or not: No
  4. Frequency of Occurrence: Regular
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Air triggers stop working. When I turn my phone off and then start it again they start to work, but right after few seconds or a minute they stop working again. I noticed this when i was playing PUBG Mobile/BGMI in India. Is this a know problem? Is there a fix?

Also noticed that if i open Game Genie to check if the triggers are active for the game or not it tends to become unresponsive. I highly doubt that this is because of Game Genie. Tried clearing its cache, but that didn't work.

Another thing, if i restart by choosing 'Restart' from power long press option the air triggers still won't work. So i have to choose power off and then start it again by button press.

Any suggestions?

Comments

  • FunBike31FunBike31 Level 4

    First of all, the behavior you notice between restarting and stopping and turning on is normal.

    We call it Warm Boot and Cold Boot

    restarting does not perform initialization and hardware check procedures and some other system tasks, it should serve only in case of software bug not related to hardware or system software, in short forget restarting, OFF-ON is preferable in 99% of cases.

    There are many posts with Air Trigger bugs, some suggestions for fixing them, but I don't remember reading a user who bothered to give feedback.


    If your Air Trigger works after a Cold Boot, the bug is software, to diagnose if it's Android 12 (or preinstalled Asus software) or if it's software you installed, you restart in safe mode then you will test the air triggers with the calculator .12345+= "Grip Sensor Test"

    If the result is Fail, all you have to do is insist strongly with Asus, don't let yourself be fooled by a proposal to change your motherboard, if he offers you this, just post it here.


    If the result is Good, it's either a corrupt system cache/data or some software or software you installed.

    You can try Settings -> Advanced -> Mobile Manager -> Cleanup

    there is also a Super clean option in Game genie.

    Then you do OFF/On

    if that doesn't solve the problem, it's software that you installed, added or not in Armory Create.

    From there, I can't help you anymore, you don't specify at all when and under what circumstances it started, you appeal to your memory and you do the reverse operations


    For Info, There is a calculator code to activate or deactivate the logs, if all these operations have failed Asus should make you activate the concerned log and ask you to send them, unless this problem has already been identified.

  • FunBike31FunBike31 Level 4

    It was totally unnecessary and even "censored" for people who reply to go squat other posts for an issue, even if it concerns Air Trigger is not the same.

    A problem = A post, it facilitates the resolution and especially the time devoted to the discussion

  • Thanks @FunBike31 for sharing detailed knowledge and troubleshooting steps. I tried the SafeMode Calculator grip test and the result is Fail.

    Also, the update - now the air triggers have stopped responding altogether. Instead when i start the phone again it vibrates rigorously 2 times, noticed something that didn't use to happen earlier.

    This is turning out to be the worst phone purchase for me, my motherboard has already been changed once because my phone turned completely dead and Asus did not extend my warranty after the new motherboard, even though this is a problem that Asus acknowledges that their ROG 5 series has. Now my 1 year warranty has expired, any suggestions if Asus would still consider it?

    I appreciate your help! Thanks a lot.

  • FunBike31FunBike31 Level 4

    Ouch, failure in safe mode is a bad sign and unfortunately there is no test in the boot prom to really test the hardware, a bug caused by Android 12 corruption during the update is still a possible cause.

    You can try to reset with Android firmware 12 to 11

    The 2 vibrations must be an indicator of the type of failure, ASUS engineers should be able to answer, at worst make you activate a log to analyze it.

    Wait until Monday and relaunch the moderators.

  • FunBike31FunBike31 Level 4
    edited July 24

    Ouch, failure in safe mode is a bad sign and unfortunately there is no test in the boot prom to really test the hardware, a bug caused by Android 12 corruption during the update is still a possible cause.

    You can try to reset with Android firmware 12 to 11

    The 2 vibrations must be an indicator of the type of failure, ASUS engineers should be able to answer, at worst make you activate a log to analyze it.

    Wait until Monday and relaunch the moderators.

  • This is a little frustrating, its just been a year + 1 month since i bought the phone and this the 2nd time seeing a major fail with the phone.

    Thanks for all your help troubleshooting @FunBike31. I think i'll just take it to Asus Service centre and let them try and solve this before i look into downgrading to Android 11.

  • Hi jasdeepgrover,

    If you are getting fail status in SMMI test, I would suggest you to visit the service center.

  • jasdeepgroverjasdeepgrover Level 1
    edited August 2

    Hi Guys, @FunBike31 @ARP_ASUS ,

    Update: Went to the service center. They changed the air triggers, and were working fine now. When i came back and installed all the apps that i use along with the games, the triggers failed again on starting BGMI app so i uninstalled it altogether thinking that this is an app issue. Now after 2 days the air triggers have stopped working altogether. The trigger test is also coming out as Fail again even after physical trigger replacement.

    Should i try downgrading to Android 11 or simply take it back to Service Center and let them figure it out?

    Also, i still couldn't find anyone else facing this issue online, or with a solution otherwise.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.