Aero cooler 3 not working with Asus Rog 3

edited August 31 in ROG Phone 3

After update to Android 12 my Aerocooler 3 not working with Asus Rog phone 3. Plz suggest something. No lights in cooler / No connectivity


  • Mat dengMat deng Level 1

    Sorry but i want to asked u. Are u can connect ur phone to laptop? If not. Then that's the problem for why ur aero cooler not functioning

  • Hello!

    For many people has been an issue with the Cache in Armoury Crate so I would recommend you clearing the cache too :D

    Just do a long press on the Armoury Crate app and select App info

    Select Storage and cache and there you can select Clear cache.

    Let me know if this works for you too :D


    Hi there,

    I tried that.

    My phone is able to charge through the fan, but it does not turn on

  • RooeyRooey Level 1

    Could be the fan is turned off? This happened to me a while back, even before update. Thought my aero cooler broke, fan wasn't spinning, but was able to charge through it's port. The setting is at the Armoury Crate > Console > Fan Speed > Slider to red.

    For some reason mine got turned off or I accidentally turned it off. Hope this helps.

  • jodybengcjodybengc Level 1
    edited August 1

    Hi guys,

    I also updated to the latest Android version.. not rooted and haven't used AeroCooler that often but after the android update...the AeroCooler is no longer working...I can still charging using it but the doesn't light up nor spin.

    I also checked the armour crate setting and put the slider to red...and still the same issue.

    Furthermore, when I connect it..the phone always says"please only use ROG3 AeroCooler 3"

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.