MediaTek MT7921 WiFi 6 Adapter "Cannot Start" + "Doesn't Exist" + BSOD (DPC Watchdog Violation)



  • @M2the2ndpower

    If the situation remains the same, according to what you described, please contact ASUS repair center in the country of your residence: Sorry for any inconvenience it may be caused. 

  • Yep. Situation remains the same.

  • itsmeitsme Level 1
    edited July 7

    Hi! I put some time into this dumb problem too. Solution was not that obvious. This got it spinning again for me.

    Some nvram stuff mess up the network card (WIFI 6 Mediatek MT7921). I tried like everything (now i got all the latest drivers as a result...) before I found this solution.

    1. Shutdown the machine
    2. Hold down the power button until the machine shutdown. It first starts up and then shuts off.
    3. Power on the machine normally with a short press on the power button.

    KUDOS to the folks finding this (it doesn't relate to Linux it seems, worked for me with w10 installed)

    (pfft... can't post links because I "haven't been around long enough" this forums tells me, thanks for trying helping out here... I'll see if can mask the url)

    *** ***

  • M2the2ndpowerM2the2ndpower Level 1
    edited July 7

    Your link seems to reference a Linix system. I run Windows.

    This didn't work no matter how many times I did the fancy reboot trick or resetting the Bios.

  • itsmeitsme Level 1

    Me too running Windows. The procedure worked for me and it makes sense that something is up with bios settings as the card was detected after bios settings was presumed cleared by doing the "long" press on the power button.

    There is a long thread about this in a Microsoft forum also, a googling should find it (don't have the link here), But there looks like there are many ways of fixing this.

    Good luck find a solution that works for you.


  • i can't access anything in the bios. Only get Simple Mode, one other mode, and the ability to look at all the icons rather than interact with them.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.