Not getting whatsapp messages when phone sleeping

nicholasgibbsnicholasgibbs Level 1
edited August 2 in ZenFone 8

When I wake phone up all my messages get delivered at once. Also I do not get Whatsapp calls while phone is sleeping. I checked in the app permissions.

Is there some kind of data saver or battery saver on that is causing this?

Comments

  • MrAvengerMrAvenger Level 2

    Yes. Change the power settings for the app as per my screenshot


  • nicholasgibbsnicholasgibbs Level 1
    edited June 15

    Thanks. Made the change and will monitor it.

    I notice you have Background app management on. Mine was off. Do I need to turn mine on as well? Detect battery draining apps is toggled on for me too.

  • MrAvengerMrAvenger Level 2

    Not sure I have it on. That setting doesn't seem to affect whatsapp messages coming through.

  • Hello @nicholasgibbs and @MrAvenger !

    I was testing this and I might have found a solution, please try the following.

    Settings -> Network & internet -> Data usage -> Mobile data usage -> WhatsApp

    In there you will see Unrestricted data usage, try turning it on if it's off and let me know if this solves the issue :)

  • MrAvengerMrAvenger Level 2

    I think this suggestion is a temp fix. So far it seems to be working for me

  • Maz DjoeMaz Djoe Level 1

    Me too... hopefully next update can fix it

  • MrAvengerMrAvenger Level 2

    ok neither has the new update fixed this issue or @Mattias_ASUS  suggestion seems to fix the issue.


    only way to get whatsapp to work properly is to set the battery usage as unrestricted

  • MaremmaMaremma Level 1

    This solution works for me(defect Born After download of new update).default set up was on optimazed:now i set It on unrestricted.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.