Storage access bug

edwardchiritaedwardchirita Level 1
edited July 26 in ZenFone 8

Hello. It appears there is a problem storage access to some apps, mostly games. I have tested this with two games: Call of Duty Mobile and Apex Legends Mobile. Call of duty mobile instantly crashes upon launch. I have emailed the developers but they haven't done anything. Apex Legends tells me I haven't given storage permission, even though it is enabled in the settings. In the settings, I can only give it access to media files and that may be the issue. I'd like to know if anyone else is facing this issue.

I am on the latest software update (31.1010.0410.72), not on any beta version and my device is not rooted. I am looking forward to steps to fix this issue or a software update to address this. Thanks in advance.


  • What I could recommend is to delete them and download them again, that way you'll be able to enable the permissions again.

  • edwardchiritaedwardchirita Level 1
    edited June 16

    Thanks but I have tried that multiple times. Also tried clearing cache and app data of the games after downloading. The issue still occurs even after this.

  • ChrisdudeChrisdude Level 1
    edited June 17

    I might have the same!

    I have an app that reads from an Shell script.

    This shell script is located in the download folder (as it should be freely accessible).

    However, once in a while the app is returning the answer that Permission to the file is denied. For days it goes well and then suddly I got this error.

    When I reboot, everything works fine again.

    I granted the app all the permissions , and indeed only access to media files can be allowed.

    Strange irregular behaviour.


  • Out of pure curiosity, are you both on Android 12? Because I have heard about some apps having issues with it and the developers are at work to solve them.

  • ChrisdudeChrisdude Level 1

    Yes, I'm on 12, firmware is .72 out of my head (latest one available)

  • Yes. Android 12. Software update 31.1010.0410.72. I'm from Europe and I have the launch model if that helps with anything.

  • ChrisdudeChrisdude Level 1

    Any news on this one?

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.