Display or driver problem.

D_IMAND_IMAN Level 2
edited August 19 in VivoBook
  1. System: Windows 11 current
  2. Battery or AC:
  3. Model: Vivobook Pro 14X OLED N7400 (X7400PC)
  4. Frequency of occurrence:
  5. Reset OS:
  6. Screenshot or video:

========================

I don't understand what's happening to my display after installing the drivers!


When I installed Windows but didn't install the video drivers yet, everything was fine.


Then I installed all the drivers from the ASUS website for my model.


But then Windows updated through the Update Center and the Microsoft Store drivers.


Appeared UWP applications panel NVIDIA\Intel and other drivers.


1. Now if I open the Intel panel UWP app, go to the "Display\Color" tab and click on the "All Colors" radio button - I can see the color changing and a slight change in brightness...


2. If I open "MyASUS" and click (not move in the direction of decrease / increase, namely, I click!) on the "oled flicker free dimming" slider, or change the "Splendid" profile, and then go back to the intel panel and click again on the switch - I see how the color changes again and a small change in brightness.


Also, if I do not do the action of 1 point, then the eyes start to bother, especially when I read the text!

(Until I make step 1 more effective, "oled flicker free dimming" doesn't help either).

The same thing I have to do when I reboot or turn on or unlock the laptop.


I also noticed that the "Video" tab in the "UWP Intel panel" control panel does not work, turning different sliders and including additional parameters, no changes / actions occur ...

UPD: Some parameters still work


It also seems to me that not all possible settings are present in the NVIDIA UWP control panel...


I also noticed how when playing videos on YouTube and YouTube short (and not only on YouTube) you can clearly see how the skin tones change to red!

I tried tweaking the color and video settings, but nothing helps, the shades are still not quite natural...

It seems that when playing a video, a different color profile is loaded ...


In the "Device Manager" there is a tab "Software Components" where there are components from video drivers, but when you try to update, Windows considers that the most appropriate / latest drivers are already installed.


Current driver versions in Device Manager:

1. NVIDIA GeForce RTX 3050 Laptop GPU - 27.21.14.6660

2. Intel(R) Iris(R) Xe Graphics - 30.0.100.9929

3. Vivobook UEFI - 10.1.2.300

Color Depth: BPC_10

Color Format: RGB

The laptop is powered by an adapter.

(But also when running on battery, the same problems).


What steps do I need to take to make the display work properly?

«1

Comments

This discussion has been closed.