cpu downclocking at capped at 1.19ghz instead of 2.84ghz

oops28oops28 Level 1
edited June 30 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG 5

Firmware Version: ZS673KS

Rooted or not:not

  1. Frequency of Occurrence:frequent
  2. APP Name & APP Version (If your issue relates to the app):bgmi mobile, pes, apex legend mobile, codm

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc

ok so idk why my TOP NOTCH ASUS ROG 5 phone cant even get me a stable 60 or 90fps. i tried almost everything from clearing cache to hardcore tunning restarting the phone. i noticed whenever my phone gets above 38*c my cpu get capped at 1.19ghz with hardcore tunning to max if not then it goes down to 845mhz and in 1.19ghz there is constant frame drops and in 845mhz the fps is like 20-30 which sucks. even saw many threads of this still doesnt get any solutions to this my phone is updated to android 12 and 31.0810.1226.77 which ig is the latest one. what one should expect with this phone which has snapdragon 888 and cant even get a stable 60 or 90fps ughh feels like i wasted my money on this, i tried calling on customer support no response , nor on email... nothing im literally tired of this shi**y performance of the phone and the customer support is just excellent. btw my phone just got its motherboard replaced like 2 months ago fix your goddamm software asus for gods sake please....


  • Hi oops28,

    Please check your PM and share the details.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.